sci-libs/vtk: removed xkaapi dependency and kaapi useflag
authorAlessandro-Barbieri <lssndrbarbieri@gmail.com>
Mon, 16 Sep 2019 13:13:44 +0000 (15:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 25 Oct 2019 09:21:47 +0000 (11:21 +0200)
Closes: https://bugs.gentoo.org/693046
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12940
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sci-libs/vtk/vtk-8.1.0-r3.ebuild

index bfe60457d8c5cdf1263d71706fe94d17d18b9297..cf30b696b29ffa81f713fbaeec751c7ef7e86205 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -26,7 +26,7 @@ LICENSE="BSD LGPL-2"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
 SLOT="0"
 IUSE="
-       all-modules aqua boost doc examples imaging ffmpeg gdal java json kaapi mpi
+       all-modules aqua boost doc examples imaging ffmpeg gdal java json mpi
        mysql odbc offscreen postgres python qt5 rendering tbb theora tk tcl
        video_cards_nvidia views web R +X xdmf2"
 
@@ -69,7 +69,6 @@ RDEPEND="
        ffmpeg? ( virtual/ffmpeg )
        gdal? ( sci-libs/gdal )
        java? ( >=virtual/jdk-1.7:* )
-       kaapi? ( <sci-libs/xkaapi-3 )
        mpi? (
                virtual/mpi[cxx,romio]
                python? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
@@ -225,9 +224,7 @@ src_configure() {
                mycmakeargs+=( -DJAVAC_OPTIONS=${javacargs// /;} )
        fi
 
-       if use kaapi; then
-               mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE="Kaapi" )
-       elif use tbb; then
+       if use tbb; then
                mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE="TBB" )
        else
                mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE="Sequential" )