dev-python/oslo-cache: 1.25.0 bup
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 27 Aug 2017 03:51:53 +0000 (22:51 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 27 Aug 2017 04:25:14 +0000 (23:25 -0500)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-python/oslo-cache/Manifest
dev-python/oslo-cache/oslo-cache-1.25.0.ebuild [new file with mode: 0644]

index 49b75744eb1400680301faa716e01698ac91984b..8b3bd1c3add0c29b6c40e0a7d87ebc98eccb9458 100644 (file)
@@ -1 +1,2 @@
 DIST oslo-cache-1.17.0.tar.gz 47178 SHA256 bd74257b5bc781112af8862ebd6d41cf58359bc78ccd421cc47f0a79d5337c64 SHA512 0ae55959a46624bd0b50cc8161f9428b3f61669f726ebc05d944f7e049c5172a1d9c83778c9632e8b2a21f047884d90d15b95c0e23a0dd19cb78f8d62f06d00e WHIRLPOOL 28c346d092cf8538a0408e4cd60d48959432090cdbb4bb00ea43524b49dceb84afa786b5456aa71a6938d99c195f940a6741ef3d06e380c5c3fe2607223a5ad0
+DIST oslo-cache-1.25.0.tar.gz 51267 SHA256 7b2e17bfb7f5de8fb7836a9e2311044cc62d904486e1cc2ad3b8182ec75e1d65 SHA512 3c21736c864cd63f3a55fe06cedad54a877970d3ede70fe9259cd549fb2a81d425547445238f8c8f9e42929b775216c79b34eead8655588ef8e1c2617bbae6a2 WHIRLPOOL ecc8bc414de18dbcb1911b3d33997884f38aa7470c537a6fc83bc8519e3d110388dee023b79d13f2b0eee300f8b144c2f0c0386023bf92af4bc71a61406a2bbf
diff --git a/dev-python/oslo-cache/oslo-cache-1.25.0.ebuild b/dev-python/oslo-cache/oslo-cache-1.25.0.ebuild
new file mode 100644 (file)
index 0000000..b655f5a
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
+       !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
+       !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+       !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
+       >=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}