dev-python/pytest-pylint: 0.14.1 version bump, EAPI=7, add RDEPEND
authorCraig Andrews <candrews@gentoo.org>
Sun, 13 Oct 2019 20:44:11 +0000 (16:44 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 15 Oct 2019 15:57:52 +0000 (11:57 -0400)
Closes: https://bugs.gentoo.org/662608
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-python/pytest-pylint/Manifest
dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild [new file with mode: 0644]

index 8511e62982229d8ac15896e26799f73ff3c3d968..55fbdf4eb1fd00214bb4860598818748cf1314aa 100644 (file)
@@ -1 +1,2 @@
+DIST pytest-pylint-0.14.1.tar.gz 8144 BLAKE2B d78892e3e606ec588b48a252db447e1cc76e27e45606670da3a3acddf040485004a7af84474732b044fdbf80ad760c07fda5e35030b9b2c9e5ce89f4809529c2 SHA512 697cd40e8e4c3722e382c7fd2dbebcb1728675e35b60396628576ec09735595af56431a2c080f29a2f35f304d912c80e4afdf0f8bd21a3adeae3156b9e58c751
 DIST pytest-pylint-0.7.1.tar.gz 5648 BLAKE2B 0baf011d9bbcfc5e66b8ea2c4fd95c8a3f8bbeedca15e2ec35d36b372b410d87ba619b0938acb26c667750c2f81d4bb09ca688731f9e184877fd999be04b6f26 SHA512 e2a7802f90ea25a909094e8bc67570eb631d6ab6dc130bb5cca1738ae09d069b4fa6c3c1349d9d62188a924138e832a3a37c8c5c8964290c95d69eecbadbd09f
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.14.1.ebuild
new file mode 100644 (file)
index 0000000..4e165ea
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to check source code with pylint"
+HOMEPAGE="https://github.com/carsongee/pytest-pylint"
+SRC_URI="https://github.com/carsongee/pytest-pylint/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+       dev-python/pylint[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest-pep8[${PYTHON_USEDEP}]
+       )"
+
+python_prepare_all() {
+       # pytest grabs the options from tox.ini automatically
+       # but setup.py does not declare pytest-pep8 as a dep,
+       # so it's missing from env created by distutils_install_for_testing
+       sed -i -e 's:--pep8::' tox.ini || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       distutils_install_for_testing
+       py.test -v || die "Tests fail with ${EPYTHON}"
+}