dev-cpp/htmlcxx: Drop old 0.86
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 13 Jan 2019 22:24:30 +0000 (22:24 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 13 Jan 2019 22:24:30 +0000 (22:24 +0000)
Package-Manager: Portage-2.3.55, Repoman-2.3.12
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
dev-cpp/htmlcxx/Manifest
dev-cpp/htmlcxx/files/0001-strstream-is-deprecated-use-sstream-instead.patch [deleted file]
dev-cpp/htmlcxx/files/0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch [deleted file]
dev-cpp/htmlcxx/htmlcxx-0.86.ebuild [deleted file]

index d686b34f837a2e9ba4dbf4e4707837a3e767e7d4..6a7558d8de92e36524560d908411e953aeba61b5 100644 (file)
@@ -1,2 +1 @@
-DIST htmlcxx-0.86.tar.gz 469416 BLAKE2B 6edd4b7755db6d8911bc4ee6b1b61792b08d6a381971162a77cd3a6c7cb6cdb06e5a4a77b0a815589edab26aec04490a6b6c9edd80199f01304a506c707688b6 SHA512 dcff9c9946e1c3429af2230997c965b89a28a8ee219d8d594800106ff578bb21154e4680c38a09fb5f96cd4051c89cbf16f2151d30be93d4e3d291ff421aafcb
 DIST htmlcxx-0.87.tar.gz 477083 BLAKE2B 94977e758b4f2643f39a464094e315c11b78bc957a3eb054e6a7608828345704a82c3ca36c5ac2855054e7570daebb80d8a63639f3a7197344d25f2d16830702 SHA512 391b94c7ea2d17a04d46ac80f8146e6c2b14b289379c40f3d432ed9c0f36222ced6384d725cdecfc352e28c30f11976249b6a3f7133bbee3161a7883d197fca7
diff --git a/dev-cpp/htmlcxx/files/0001-strstream-is-deprecated-use-sstream-instead.patch b/dev-cpp/htmlcxx/files/0001-strstream-is-deprecated-use-sstream-instead.patch
deleted file mode 100644 (file)
index 822c1c8..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-From 04fbe8cb7d933699f2a8ac06d89b205d933070c1 Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Wed, 14 Sep 2016 22:56:14 +0100
-Subject: [PATCH 1/3] strstream is deprecated, use sstream instead
-
----
- html/Uri.cc   | 2 +-
- html/utils.cc | 5 ++---
- 2 files changed, 3 insertions(+), 4 deletions(-)
-
-diff --git a/html/Uri.cc b/html/Uri.cc
-index 4ddb3dd..034d29a 100644
---- a/html/Uri.cc
-+++ b/html/Uri.cc
-@@ -1,7 +1,7 @@
- #include "Uri.h"
- #include "wincstring.h"
--#include <strstream>
-+#include <sstream>
- #include <cstdlib>
- #include <cassert>
- #include "tld.h"
-diff --git a/html/utils.cc b/html/utils.cc
-index 37ee889..e56cbaf 100644
---- a/html/utils.cc
-+++ b/html/utils.cc
-@@ -1,7 +1,7 @@
- #include <algorithm>
- #include <cctype>
- #include <cstring>
--#include <strstream>
-+#include <sstream>
- #include "Uri.h"
- #include "utils.h"
-@@ -509,7 +509,7 @@ namespace htmlcxx {
-               string __serialize_gml(const tree<HTML::Node> &tr, tree<HTML::Node>::iterator it, tree<HTML::Node>::iterator end, unsigned int parent_id, unsigned int& label) {
-                       using namespace std;
--                      ostrstream ret;
-+                      ostringstream ret;
-                       tree<HTML::Node>::sibling_iterator sib = tr.begin(it);
-                       while(sib != tr.end(it)) {
-                               ret << "node [ id " << ++label << "\n label \"" << label << "\"\n]\n";
-@@ -519,7 +519,6 @@ namespace htmlcxx {
-                       }       
-                       ret << ends;
-                       string str = ret.str();
--                      ret.freeze(0);
-                       return str;
-               }
--- 
-2.8.2
-
diff --git a/dev-cpp/htmlcxx/files/0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch b/dev-cpp/htmlcxx/files/0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch
deleted file mode 100644 (file)
index c387dee..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-From 807081583ea58b07a5ff2e0659f4173492befb8a Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Wed, 14 Sep 2016 22:56:35 +0100
-Subject: [PATCH 2/3] Update css_syntax.y for use with less ancient Bison
-
-New pregenerated css_syntax.c to follow.
----
- css/css_syntax.y | 24 +++++++++++++++---------
- 1 file changed, 15 insertions(+), 9 deletions(-)
-
-diff --git a/css/css_syntax.y b/css/css_syntax.y
-index e75720d..0d9b177 100644
---- a/css/css_syntax.y
-+++ b/css/css_syntax.y
-@@ -4,13 +4,13 @@
- #include "css_lex.h"
- #include "parser.h"
--#define YYPARSE_PARAM yyparam
- #define YYERROR_VERBOSE 1
- //#define YYDEBUG 1
- %}
--%pure_parser
-+%parse-param {void *yyparam}
-+%pure-parser
- %union {
-       char *lexeme;
-@@ -22,6 +22,19 @@
-       int pseudo_element;
- }
-+%{
-+
-+int yylex(YYSTYPE *lvalp);
-+
-+int yyerror(void *yyparam, const char *s) {
-+#if YYDEBUG
-+      fprintf(stderr, "Error: %s\n", s);
-+#endif
-+      return 0;
-+}
-+
-+%}
-+
- %token IMPORT_SYM
- %token IMPORTANT_SYM
- %token IDENT
-@@ -571,13 +584,6 @@ hexcolor
- %%
--int yyerror(char *s) {
--#if YYDEBUG
--      fprintf(stderr, "Error: %s\n", s);
--#endif
--      return 0;
--}
--
- struct selector_list_t* css_parse(const char *buffer, int buf_len) {
-       struct selector_list_t *ret = NULL;
-       //yydebug = 1;
--- 
-2.8.2
-
diff --git a/dev-cpp/htmlcxx/htmlcxx-0.86.ebuild b/dev-cpp/htmlcxx/htmlcxx-0.86.ebuild
deleted file mode 100644 (file)
index 88d48de..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils multilib-minimal
-
-DESCRIPTION="A simple non-validating CSS 1 and HTML parser for C++"
-HOMEPAGE="http://htmlcxx.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-
-DEPEND="sys-devel/flex[${MULTILIB_USEDEP}]
-       virtual/yacc"
-
-PATCHES=(
-       "${FILESDIR}"/0001-strstream-is-deprecated-use-sstream-instead.patch
-       "${FILESDIR}"/0002-Update-css_syntax.y-for-use-with-less-ancient-Bison.patch
-)
-
-ECONF_SOURCE="${S}"
-
-multilib_src_configure() {
-       econf \
-               --enable-shared \
-               $(use_enable static-libs static)
-}
-
-multilib_src_install_all() {
-       prune_libtool_files
-       einstalldocs
-}