CFLAGS += -std=c99 -Dsmall $(WARNFLAGS) \
- -D_BSD_SOURCE \
-+ -D_DEFAULT_SOURCE \
++ -D_BSD_SOURCE -D_DEFAULT_SOURCE \
-D_XOPEN_SOURCE=600 \
-D_POSIX_C_SOURCE=200112L \
$(shell $(PKG_CONFIG) --cflags libnsfb libhubbub libcss openssl)
GTKCFLAGS := -std=c99 -Dgtk -Dnsgtk \
$(GTKDEPFLAGS) \
- -D_BSD_SOURCE \
-+ -D_DEFAULT_SOURCE \
++ -D_BSD_SOURCE -D_DEFAULT_SOURCE \
-D_XOPEN_SOURCE=600 \
-D_POSIX_C_SOURCE=200809L \
-D_NETBSD_SOURCE \
+++ netsurf-3.2/test/Makefile
@@ -1,4 +1,4 @@
-CFLAGS := -std=c99 -D_BSD_SOURCE -D_POSIX_C_SOURCE -I.. \
-+CFLAGS := -std=c99 -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE -I.. \
++CFLAGS := -std=c99 -D_BSD_SOURCE -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE -I.. \
$(shell pkg-config --cflags libcurl)
LDFLAGS := $(shell pkg-config --libs libcurl) -lz
+GTKCFLAGS := -std=c99 -Dgtk -Dnsgtk \
$(GTKDEPFLAGS) \
- -D_BSD_SOURCE \
-+ -D_DEFAULT_SOURCE \
++ -D_BSD_SOURCE -D_DEFAULT_SOURCE \
-D_XOPEN_SOURCE=600 \
-D_POSIX_C_SOURCE=200809L \
-D_NETBSD_SOURCE \
+++ netsurf-3.3/test/Makefile
@@ -1,8 +1,8 @@
-CFLAGS := -std=c99 -g -O0 -D_BSD_SOURCE -D_POSIX_C_SOURCE -I.. \
-+CFLAGS := -std=c99 -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE -I.. \
++CFLAGS := -std=c99 -D_BSD_SOURCE -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE -I.. \
$(shell pkg-config --cflags libcurl)
LDFLAGS := $(shell pkg-config --libs libcurl) -lz
netsurf_src_install
elog "framebuffer binary has been installed as netsurf-fb"
pushd "${ED}"usr/bin >/dev/null || die
- for f in netsurf{,.*} ; do
+ eshopts_push -s nullglob
+ # bug 552562
+ local binaries=(netsurf{,.*})
+ eshopts_pop
+ for f in "${binaries[@]}" ; do
mv -v $f ${f/netsurf/netsurf-fb} || die
make_desktop_entry "${EROOT}"usr/bin/${f/netsurf/netsurf-fb} NetSurf-framebuffer${f/netsurf} netsurf "Network;WebBrowser"
done
netsurf_src_install
elog "netsurf gtk version has been installed as netsurf-gtk"
pushd "${ED}"usr/bin >/dev/null || die
- for f in netsurf{,.*} ; do
+ eshopts_push -s nullglob
+ # bug 552562
+ local binaries=(netsurf{,.*})
+ eshopts_pop
+ for f in "${binaries[@]}" ; do
mv -v $f ${f/netsurf/netsurf-gtk} || die
make_desktop_entry "${EROOT}"usr/bin/${f/netsurf/netsurf-gtk} NetSurf-gtk${f/netsurf} netsurf "Network;WebBrowser"
done