app-emulation/virtualbox: Minor ebuild improvements
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 9 May 2019 13:06:01 +0000 (15:06 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 9 May 2019 13:06:27 +0000 (15:06 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-emulation/virtualbox/virtualbox-6.0.6-r1.ebuild

index ac99dd66bda21eb35d0692c443b46e245ea3273f..627195b1a4d637ad161dd810aa6266785ef5a94b 100644 (file)
@@ -262,9 +262,7 @@ src_compile() {
 }
 
 src_install() {
-       local binpath="release"
-       use debug && binpath="debug"
-       cd "${S}"/out/linux.${ARCH}/${binpath}/bin || die
+       cd "${S}"/out/linux.${ARCH}/$(usex debug debug release)/bin || die
 
        local vbox_inst_path="/usr/$(get_libdir)/${PN}" each size ico icofile
 
@@ -489,7 +487,7 @@ pkg_postinst() {
                elog ""
                elog "WARNING!"
                elog "Without USE=udev, USB devices will likely not work in ${PN}."
-       elif [ -e "${ROOT%/}/etc/udev/rules.d/10-virtualbox.rules" ] ; then
+       elif [[ -e "${ROOT%/}/etc/udev/rules.d/10-virtualbox.rules" ]] ; then
                elog ""
                elog "Please remove \"${ROOT%/}/etc/udev/rules.d/10-virtualbox.rules\""
                elog "or else USB in ${PN} won't work."