dev-php/PEAR-PEAR_PackageFileManager_Plugins: Revbump to fix WORKDIR wrt bug 613122
authorBrian Evans <grknight@gentoo.org>
Sun, 19 Mar 2017 14:47:56 +0000 (10:47 -0400)
committerBrian Evans <grknight@gentoo.org>
Sun, 19 Mar 2017 14:47:56 +0000 (10:47 -0400)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4-r1.ebuild [new file with mode: 0644]
dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild [deleted file]

diff --git a/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4-r1.ebuild b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4-r1.ebuild
new file mode 100644 (file)
index 0000000..0219653
--- /dev/null
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Various methods to check files to update an existing package.xml file"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-php/PEAR-PEAR-1.10.1
+       >=dev-php/PEAR-XML_Serializer-0.19.0
+       >=dev-lang/php-5.3:*[xml,simplexml]"
diff --git a/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild
deleted file mode 100644 (file)
index 2d32e7a..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-HOMEPAGE="http://pear.php.net/package/${MY_PN}"
-SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
-DESCRIPTION="Various methods to check files to update an existing package.xml file"
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-php/PEAR-PEAR-1.10.1
-       >=dev-php/PEAR-XML_Serializer-0.19.0
-       >=dev-lang/php-5.3:*[xml,simplexml]"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
-       insinto /usr/share/php
-       doins -r PEAR
-}
-
-pkg_postinst() {
-       # Register the package from the package.xml file
-       # Operation is not critical so die is not required
-       if [[ -f "${WORKDIR}/package.xml" ]] ; then
-               "${EROOT}usr/bin/peardev" install -nrO --force "${WORKDIR}/package.xml" 2> /dev/null
-       fi
-}
-
-pkg_postrm() {
-       # Uninstall known dependency
-       "${EROOT}usr/bin/peardev" uninstall -nrO "pear.php.net/${MY_PN}"
-}