dev-ml/xml-light: Remove old
authorAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 07:43:37 +0000 (08:43 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 09:15:49 +0000 (10:15 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/xml-light/xml-light-2.2-r1.ebuild [deleted file]
dev-ml/xml-light/xml-light-2.2-r2.ebuild [deleted file]

diff --git a/dev-ml/xml-light/xml-light-2.2-r1.ebuild b/dev-ml/xml-light/xml-light-2.2-r1.ebuild
deleted file mode 100644 (file)
index b2f8489..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils multilib
-
-DESCRIPTION="Minimal Xml parser and printer for OCaml"
-HOMEPAGE="http://tech.motion-twin.com/xmllight.html"
-SRC_URI="http://tech.motion-twin.com/zip/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-DEPEND="app-arch/unzip
-       dev-lang/ocaml
-       doc? ( dev-ml/ocaml-doc )"
-RDEPEND="dev-lang/ocaml"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
-       EPATCH_FORCE=yes EPATCH_SUFFIX=dpatch EPATCH_SOURCE="${FILESDIR}" \
-       epatch
-}
-
-src_compile() {
-       emake -j1
-       if use doc;then
-               emake doc
-       fi
-}
-
-src_install() {
-       dodir /usr/$(get_libdir)/ocaml
-       emake INSTALLDIR="${D}"/usr/$(get_libdir)/ocaml install
-       dodoc README
-       if use doc; then
-               emake doc
-               dohtml doc/*
-       fi
-}
diff --git a/dev-ml/xml-light/xml-light-2.2-r2.ebuild b/dev-ml/xml-light/xml-light-2.2-r2.ebuild
deleted file mode 100644 (file)
index 4f2636a..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib
-
-DESCRIPTION="Minimal Xml parser and printer for OCaml"
-HOMEPAGE="http://tech.motion-twin.com/xmllight.html"
-SRC_URI="http://tech.motion-twin.com/zip/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-RDEPEND="dev-lang/ocaml:="
-DEPEND="app-arch/unzip
-       ${RDEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
-       EPATCH_FORCE=yes EPATCH_SUFFIX=dpatch EPATCH_SOURCE="${FILESDIR}" \
-       epatch
-}
-
-src_compile() {
-       emake -j1
-       if use doc;then
-               emake doc
-       fi
-}
-
-src_install() {
-       dodir /usr/$(get_libdir)/ocaml/${PN}
-       emake INSTALLDIR="${D}"/usr/$(get_libdir)/ocaml/${PN} install
-       cat > "${D}"/usr/$(get_libdir)/ocaml/${PN}/META << EOF
-name="${PN}"
-version="${PV}"
-description="${DESCRIPTION}"
-requires=""
-archive(byte) = "xml-light.cma"
-EOF
-       dodoc README
-       if use doc; then
-               emake doc
-               dohtml doc/*
-       fi
-}