net-libs/nodejs: add USE=+system-ssl
authorStefan Strogin <steils@gentoo.org>
Sun, 26 Jan 2020 14:34:35 +0000 (16:34 +0200)
committerStefan Strogin <steils@gentoo.org>
Tue, 25 Feb 2020 05:17:13 +0000 (07:17 +0200)
For now net-libs/nodejs fails to build on LibreSSL systems.
Add USE=+system-ssl which can be explicitly disabled in order to use
bundled OpenSSL.

Bug: https://bugs.gentoo.org/613344
Closes: https://github.com/gentoo/gentoo/pull/14460
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Stefan Strogin <steils@gentoo.org>
net-libs/nodejs/metadata.xml
net-libs/nodejs/nodejs-10.19.0.ebuild
net-libs/nodejs/nodejs-12.16.1.ebuild
net-libs/nodejs/nodejs-13.9.0.ebuild
net-libs/nodejs/nodejs-99999999.ebuild

index 3f344f0d8eda51ae9f8597911c9b1dce2094ef2a..3e9bb1da9c023d070c03f072637c881349cdac10 100644 (file)
@@ -9,6 +9,7 @@
                <flag name="npm">Enable NPM package manager</flag>
                <flag name="pax_kernel">Enable building under a PaX enabled kernel</flag>
                <flag name="snapshot">Enable snapshot creation for faster startup</flag>
+               <flag name="system-ssl">Use system OpenSSL instead of the bundled one</flag>
                <flag name="systemtap">Enable SystemTAP/DTrace tracing</flag>
        </use>
 </pkgmetadata>
index 31d605f6adb246fae0a63fc88719257c7e3727ea..db37b4f351895da4baf0541d35a988241ba9ccdd 100644 (file)
@@ -13,10 +13,11 @@ SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
 LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl +system-ssl systemtap test"
 REQUIRED_USE="
        inspector? ( icu ssl )
        npm? ( ssl )
+       system-ssl? ( ssl )
 "
 
 RDEPEND="
@@ -26,7 +27,7 @@ RDEPEND="
        >=net-libs/nghttp2-1.39.2
        sys-libs/zlib
        icu? ( >=dev-libs/icu-64.2:= )
-       ssl? ( >=dev-libs/openssl-1.1.1:0= )
+       system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
 "
 DEPEND="
        ${RDEPEND}
@@ -99,7 +100,7 @@ src_configure() {
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
        use snapshot && myconf+=( --with-snapshot )
-       use ssl && myconf+=( --shared-openssl ) || myconf+=( --without-ssl )
+       use ssl && ( use system-ssl && myconf+=( --shared-openssl ) ) || myconf+=( --without-ssl )
 
        local myarch=""
        case ${ABI} in
index 3850f958b73f357770edecf68a959818aa5f01cd..6c929f7027868df679703e1a00a1af4b1506de9a 100644 (file)
@@ -15,10 +15,11 @@ SRC_URI="
 LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl +system-ssl systemtap test"
 REQUIRED_USE="
        inspector? ( icu ssl )
        npm? ( ssl )
+       system-ssl? ( ssl )
 "
 
 RDEPEND="
@@ -28,7 +29,7 @@ RDEPEND="
        >=net-libs/nghttp2-1.40.0
        sys-libs/zlib
        icu? ( >=dev-libs/icu-64.2:= )
-       ssl? ( >=dev-libs/openssl-1.1.1:0= )
+       system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
 "
 BDEPEND="
        ${PYTHON_DEPS}
@@ -106,7 +107,7 @@ src_configure() {
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
        use snapshot || myconf+=( --without-node-snapshot )
-       use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
+       use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
 
        local myarch=""
        case ${ABI} in
index aefd3239857af1d2675781e2c511e856250889df..4d35b0880936f8e0dc82097e975dea5fe4c4b16b 100644 (file)
@@ -15,10 +15,11 @@ SRC_URI="
 LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm pax_kernel +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm pax_kernel +snapshot +ssl +system-ssl systemtap test"
 REQUIRED_USE="
        inspector? ( icu ssl )
        npm? ( ssl )
+       system-ssl? ( ssl )
 "
 
 RDEPEND="
@@ -27,7 +28,7 @@ RDEPEND="
        >=net-libs/nghttp2-1.40.0
        sys-libs/zlib
        icu? ( >=dev-libs/icu-64.2:= )
-       ssl? ( >=dev-libs/openssl-1.1.1:0= )
+       system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
 "
 BDEPEND="
        ${PYTHON_DEPS}
@@ -104,7 +105,7 @@ src_configure() {
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
        use snapshot || myconf+=( --without-node-snapshot )
-       use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
+       use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
 
        local myarch=""
        case ${ABI} in
index 00962bc7bcbf0ff500c7c7027019a6ee0ee43fb7..71618f3c5232651303f71395fcddd0aa6ed0b961 100644 (file)
@@ -13,11 +13,12 @@ EGIT_REPO_URI="https://github.com/nodejs/node"
 LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
 SLOT="0"
 KEYWORDS=""
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm pax_kernel +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm pax_kernel +snapshot +ssl +system-ssl systemtap test"
 RESTRICT="!test? ( test )"
 REQUIRED_USE="
        inspector? ( icu ssl )
        npm? ( ssl )
+       system-ssl? ( ssl )
 "
 
 RDEPEND="
@@ -26,7 +27,7 @@ RDEPEND="
        >=net-libs/nghttp2-1.39.2
        sys-libs/zlib
        icu? ( >=dev-libs/icu-64.2:= )
-       ssl? ( >=dev-libs/openssl-1.1.1:0= )
+       system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
 "
 BDEPEND="
        ${PYTHON_DEPS}
@@ -101,7 +102,7 @@ src_configure() {
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
        use snapshot || myconf+=( --without-node-snapshot )
-       use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
+       use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
 
        local myarch=""
        case ${ABI} in