sys-boot/vboot-utils: fix libressl support, musl dep fix
authorJory Pratt <anarchy@gentoo.org>
Thu, 13 Jun 2019 01:52:17 +0000 (20:52 -0500)
committerJory Pratt <anarchy@gentoo.org>
Thu, 13 Jun 2019 01:52:40 +0000 (20:52 -0500)
Closes: https://bugs.gentoo.org/678594
Closes: https://bugs.gentoo.org/687820
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Jory Pratt <anarchy@gentoo.org>
sys-boot/vboot-utils/files/vboot-utils-72_p20181229-libressl.patch [new file with mode: 0644]
sys-boot/vboot-utils/vboot-utils-72_p20181229-r1.ebuild [moved from sys-boot/vboot-utils/vboot-utils-72_p20181229.ebuild with 98% similarity]

diff --git a/sys-boot/vboot-utils/files/vboot-utils-72_p20181229-libressl.patch b/sys-boot/vboot-utils/files/vboot-utils-72_p20181229-libressl.patch
new file mode 100644 (file)
index 0000000..6702a9f
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/host/include/openssl_compat.h    2019-01-03 17:32:20.000000000 -0500
++++ b/host/include/openssl_compat.h    2019-02-23 13:40:27.521664838 -0500
+@@ -12,7 +12,7 @@
+ #include <openssl/rsa.h>
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || LIBRESSL_VERSION_NUMBER < 0x2080000L
+ static inline void RSA_get0_key(const RSA *rsa, const BIGNUM **n,
+                               const BIGNUM **e, const BIGNUM **d)
similarity index 98%
rename from sys-boot/vboot-utils/vboot-utils-72_p20181229.ebuild
rename to sys-boot/vboot-utils/vboot-utils-72_p20181229-r1.ebuild
index 273d3ec48ff2d7727fccc9c707cede3f4cacd326..a6628bdafb373d4b7240007e0632024444bc306a 100644 (file)
@@ -42,6 +42,8 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}
 
 src_prepare() {
+       eapply "${FILESDIR}"/${P}-libressl.patch
+
        default
        sed -i \
                -e 's:${DESTDIR}/\(bin\|${LIBDIR}\):${DESTDIR}/usr/\1:g' \