net-im/libcommuni: bump to version 3.5.0_p20190110
authorConrad Kostecki <conrad@kostecki.com>
Sat, 21 Sep 2019 21:03:25 +0000 (23:03 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 24 Sep 2019 03:40:01 +0000 (06:40 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Closes: https://github.com/gentoo/gentoo/pull/12999
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-im/libcommuni/Manifest
net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild [new file with mode: 0644]

index 7670d11af66fbad8ba31db728c10f0262837b047..6d372f54681786e2ed7afb7fbae07ab507fe5363 100644 (file)
@@ -1 +1,2 @@
 DIST libcommuni-3.5.0_p20180116.tar.gz 471286 BLAKE2B 9f89a5eea2444c207b54f6b820c7cef89ff2e578d34ad751fdbfe558af2bcf0e52238ef63b244fb321baa7716c0119ca084c547cc0161a08b46af4c9d604dd0e SHA512 f7ce9c92acbd67b3d75b9b7fc1cef55796a3d44294024da591c7b0c21fc065ec484dbc6a4c83af96fcb6fd6e725a7b6ed4219bd09e2aa0de303b82d64741efba
+DIST libcommuni-3.5.0_p20190110.tar.gz 471278 BLAKE2B 2836a5ae01b08aac624c899a40712a9c452fc5b8f242906063936e48bd59306758cc70ea07beaf8488d228d6029c8128e343bbd59b1bfeff9bb2dccda0153b59 SHA512 9da065ef6b0589f7406d8c66b46f9f8d3d16325b59b7281153233b1a8d2bf98cdd35ee4e416237ac760dfc07531578aa7432226932976b9bbf36209bed5db72c
diff --git a/net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild b/net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild
new file mode 100644 (file)
index 0000000..484a8cc
--- /dev/null
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="88bb0fcdaab5bdd1176a3b6b485a6415a137ec27"
+
+inherit qmake-utils
+
+DESCRIPTION="A cross-platform IRC framework written with Qt"
+HOMEPAGE="https://communi.github.io/"
+SRC_URI="https://github.com/communi/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples qml test +uchardet"
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtdeclarative:5
+       examples? ( dev-qt/qtgui:5[xcb] )
+       uchardet? ( app-i18n/uchardet )
+       !uchardet? ( dev-libs/icu:= )
+"
+
+DEPEND="
+       ${RDEPEND}
+       test? ( dev-qt/qttest:5 )
+"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+       default
+
+       # Currently the test tst_IrcLagTimer fails, so disabling
+       # See: https://github.com/communi/libcommuni/issues/63
+       sed -e '/irclagtimer/d' -i tests/auto/auto.pro || die
+}
+
+src_configure() {
+       local myqmakeargs=( libcommuni.pro
+               # Disables compile run-time benchmarks, as they don't make any sense
+               -config no_benchmarks
+               # Is needed for fixing the QA Notice: The following files contain insecure RUNPATHs
+               -config no_rpath
+               # Compile libcommuni always in Release mode, as Debug seems to do nothing
+               -config release
+               # Don't silence all compile messages
+               -config verbose
+               -config $(usex examples '' 'no_')examples
+               -config $(usex qml '' 'no_')install_imports
+               -config $(usex qml '' 'no_')install_qml
+               -config $(usex test '' 'no_')tests
+               -config $(usex uchardet 'no_' '')icu
+               -config $(usex uchardet '' 'no_')uchardet )
+
+       eqmake5 "${myqmakeargs[@]}"
+}
+
+src_test() {
+       # This is a hack to delete the existing LD_LIBRARY_PATH and set a new one,
+       # otherwise a test will fail, because it uses the system installed lib instead of the new compiled lib.
+       # The test will fail, when libcommuni is emerged with USE="uchardet" and
+       # libcommuni is already installed with USE="-uchardat", or the other way around.
+       find "${S}" -type f -name 'target_wrapper.sh' -exec sed -i -e "/.*LD_LIBRARY_PATH.*/d" {} \; || die
+       local -x LD_LIBRARY_PATH="${S}/lib"
+
+       default
+}
+
+src_install() {
+       emake install INSTALL_ROOT="${D}"
+
+       if use examples; then
+               local examples=( "bot" "client" "minimal" "qmlbot" "quick" )
+               for example in ${examples[@]}; do
+                       newbin examples/"${example}"/"${example}" libcommuni."${example}"
+               done
+       fi
+
+       einstalldocs
+}