projects
/
gentoolkit.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
43d52f7
)
Use svn cp instead of cp if vcs == svn, thanks to Justin Lecher (jlec) <jlec@j-schmit...
author
idl0r
<idl0r@gentoo.org>
Sun, 19 Jul 2009 15:42:35 +0000
(15:42 -0000)
committer
idl0r
<idl0r@gentoo.org>
Sun, 19 Jul 2009 15:42:35 +0000
(15:42 -0000)
svn path=/trunk/gentoolkit-dev/; revision=666
src/ebump/ebump
patch
|
blob
|
history
diff --git
a/src/ebump/ebump
b/src/ebump/ebump
index d3d2f100a71cd27a8906651aecf2cb1a41d95eea..b877318c26bcfb2d00d35b07a609e1c07a9b9fd3 100755
(executable)
--- a/
src/ebump/ebump
+++ b/
src/ebump/ebump
@@
-165,7
+165,12
@@
process_ebuild() {
einfo "Bumped ${PF}.ebuild to ${newPF}.ebuild"
- cp ${PF}.ebuild ${newPF}.ebuild
+ if [[ "${vcs}" == "svn" ]];
+ then
+ svn cp ${PF}.ebuild ${newPF}.ebuild
+ else
+ cp ${PF}.ebuild ${newPF}.ebuild
+ fi
einfo "Reset keywords to ~arch"