arm/ia64/s390/sh stable
authorMike Frysinger <vapier@gentoo.org>
Sat, 10 Mar 2007 22:26:12 +0000 (22:26 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 10 Mar 2007 22:26:12 +0000 (22:26 +0000)
app-editors/nano/nano-2.0.3.ebuild

index 984b97ac83213cc2b55501a70786264890a6769a..4d24d2d3a9319c469210f1eeb26ce1f8e9b03ced 100644 (file)
@@ -1,21 +1,24 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.0.3.ebuild,v 1.2 2007/02/28 21:56:14 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.0.3.ebuild,v 1.3 2007/03/10 22:26:12 vapier Exp $
 
-#ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
-#ECVS_MODULE="nano"
-#ECVS_AUTH="pserver"
-#ECVS_USER="anonymous"
-#inherit cvs
+if [[ ${PV} == "9999" ]] ; then
+       ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
+       ECVS_MODULE="nano"
+       ECVS_AUTH="pserver"
+       ECVS_USER="anonymous"
+       inherit cvs
+else
+       SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+fi
 
 MY_P=${PN}-${PV/_}
 DESCRIPTION="GNU GPL'd Pico clone with more functionality"
 HOMEPAGE="http://www.nano-editor.org/"
-SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 arm ~hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
 IUSE="debug justify minimal ncurses nls slang spell unicode"
 
 DEPEND=">=sys-libs/ncurses-5.2