dev-perl/DateTime-HiRes: EAPI6 + Tests
authorKent Fredric <kentnl@gentoo.org>
Fri, 20 Oct 2017 02:59:59 +0000 (15:59 +1300)
committerKent Fredric <kentnl@gentoo.org>
Fri, 20 Oct 2017 07:39:45 +0000 (20:39 +1300)
- EAPI6
- Enable tests
- Fix tests against newer DateTime

Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-perl/DateTime-HiRes/DateTime-HiRes-0.10.0-r1.ebuild [new file with mode: 0644]
dev-perl/DateTime-HiRes/files/DateTime-HiRes-0.10.0-datetimelocale.patch [new file with mode: 0644]

diff --git a/dev-perl/DateTime-HiRes/DateTime-HiRes-0.10.0-r1.ebuild b/dev-perl/DateTime-HiRes/DateTime-HiRes-0.10.0-r1.ebuild
new file mode 100644 (file)
index 0000000..8663f56
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=JHOBLITT
+DIST_VERSION=0.01
+inherit perl-module
+
+DESCRIPTION="Create DateTime objects with sub-second current time resolution"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/DateTime"
+DEPEND="${RDEPEND}
+       dev-perl/Module-Build"
+PATCHES=("${FILESDIR}/${P}-datetimelocale.patch" )
diff --git a/dev-perl/DateTime-HiRes/files/DateTime-HiRes-0.10.0-datetimelocale.patch b/dev-perl/DateTime-HiRes/files/DateTime-HiRes-0.10.0-datetimelocale.patch
new file mode 100644 (file)
index 0000000..37847c4
--- /dev/null
@@ -0,0 +1,39 @@
+From 39dca8357ffbc562d1a4138586795a32e2a0c8ea Mon Sep 17 00:00:00 2001
+From: Roy Ivy III <rivy.dev@gmail.com>
+Date: Mon, 6 Jun 2016 14:03:59 -0500
+Subject: fix locale testing bug, accepting both old and new canonical locale
+ forms
+
+* fixes #1
+* fixes [rt-bug#109088]
+
+.# Discussion
+
+In v1.00, DateTime::Locale changed the canonical form of locale to use dashes instead of
+underscrores (see [1]). This causes a failure within the "t/02_now.t" test, blocking
+unforced installs.
+
+refs
+[1] https://github.com/autarch/DateTime-Locale/blob/v1.00/Changes#L44
+[rt-bug#109088] https://rt.cpan.org/Public/Bug/Display.html?id=109088 @@ https://archive.is/3RccB
+
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=109088
+Bug: https://github.com/jhoblitt/DateTime-HiRes/pull/2
+---
+ t/02_now.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/02_now.t b/t/02_now.t
+index 4eb1f74..fc55184 100644
+--- a/t/02_now.t
++++ b/t/02_now.t
+@@ -32,5 +32,5 @@ use DateTime::HiRes;
+             );
+     is( $dt->time_zone_long_name, 'Africa/Cairo', "accepted time_zone parameter" );
+-    is( $dt->locale->id, 'ar_EG', "accepted locale parameter" );
++    like( $dt->locale->id, qr'ar[_-]EG', "accepted locale parameter" );
+ }
+-- 
+2.14.2
+