dev-python/pygments: Enable py3.8
authorMichał Górny <mgorny@gentoo.org>
Sun, 24 Nov 2019 17:07:53 +0000 (18:07 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 24 Nov 2019 17:07:53 +0000 (18:07 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pygments/pygments-2.4.2.ebuild

index 4c819c2a0479bcb782b968564f7b19e4c2cae657..04253a224e2b0c42d4f68bf69d33943d097cf25a 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
 
 inherit distutils-r1 bash-completion-r1
 
@@ -22,7 +22,7 @@ RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
        test? (
                dev-python/nose[${PYTHON_USEDEP}]
                virtual/ttf-fonts
@@ -30,6 +30,11 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}/${MY_P}"
 
+python_check_deps() {
+       use doc || return 0
+       has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
 python_compile_all() {
        use doc && emake -C doc html
 }