media-video/dcpomatic: Initial import.
authorMichael Weber <xmw@gentoo.org>
Sat, 4 Mar 2017 11:21:58 +0000 (12:21 +0100)
committerMichael Weber <xmw@gentoo.org>
Sat, 4 Mar 2017 11:24:13 +0000 (12:24 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

media-video/dcpomatic/Manifest [new file with mode: 0644]
media-video/dcpomatic/dcpomatic-2.10.2.ebuild [new file with mode: 0644]
media-video/dcpomatic/dcpomatic-2.9.0.ebuild [new file with mode: 0644]
media-video/dcpomatic/files/dcpomatic-2.10.2-respect-cxxflags.patch [new file with mode: 0644]
media-video/dcpomatic/files/dcpomatic-2.8.0-desktop.patch [new file with mode: 0644]
media-video/dcpomatic/files/dcpomatic-2.8.0-no-ldconfig.patch [new file with mode: 0644]
media-video/dcpomatic/files/dcpomatic-2.8.0-wxGTK3.patch [new file with mode: 0644]
media-video/dcpomatic/metadata.xml [new file with mode: 0644]

diff --git a/media-video/dcpomatic/Manifest b/media-video/dcpomatic/Manifest
new file mode 100644 (file)
index 0000000..85327d3
--- /dev/null
@@ -0,0 +1,2 @@
+DIST dcpomatic-2.10.2.tar.bz2 37503820 SHA256 18182dda94de584299e660db3e232be8d98be5aa99255561154eb2048f3c2211 SHA512 dc4fff96db31ee7645cdc9aac59b37a8dc37f2d77287c41bd4da4df074802a518d4b9c0e5143272d50d2dfee03d46b4ac761c0423b51b327185aae0510c0deb5 WHIRLPOOL ed8b0d780e5ea50eae0bcce6ad1f2a087f9b8d703516fb3e1abe246af79bbeb92a18552642bb4517e5f2604856308ffe39bf47891e0dc59cac357c9866e2f52a
+DIST dcpomatic-2.9.0.tar.bz2 37453226 SHA256 4596bb660e5339c6a633ceb40656d2787405ad91b706080335b1b466e17f920d SHA512 23a0882265b21ff6f7d74d4fdd10fc49a2427d907a6de1dec9f2b51ee5a4bc9a98f405adb2153214f43820887f7d481220ca25e762f253d31976e3ff2687fc0a WHIRLPOOL e49e866b7c4936a915d140dedb13764437c080080b36cd94796c6ae6d9c20ddb451600ebc00614bbe8ba55fea280e3285f073a0ab5029e72888f6080941b5d2c
diff --git a/media-video/dcpomatic/dcpomatic-2.10.2.ebuild b/media-video/dcpomatic/dcpomatic-2.10.2.ebuild
new file mode 100644 (file)
index 0000000..7456ff6
--- /dev/null
@@ -0,0 +1,96 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils wxwidgets
+
+DESCRIPTION="create Digital Cinema Packages (DCPs) from videos, images and sound files"
+HOMEPAGE="http://dcpomatic.com/"
+SRC_URI="http://${PN}.com/downloads/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gtk"
+
+RDEPEND="dev-cpp/cairomm
+       dev-cpp/glibmm:2
+       dev-cpp/libxmlpp:2.6
+       dev-cpp/pangomm:1.4
+       dev-libs/boost
+       dev-libs/glib:2
+       dev-libs/icu
+       dev-libs/libcxml
+       dev-libs/libzip
+       dev-libs/openssl:0
+       || ( media-gfx/graphicsmagick media-gfx/imagemagick )
+       media-libs/fontconfig:1.0
+       >=media-libs/libdcp-1.4.1:1.0
+       media-libs/libsamplerate
+       media-libs/libsndfile
+       >=media-libs/libsub-1.2.1:1.0
+       >=media-video/ffmpeg-3:=
+       net-libs/libssh
+       net-misc/curl
+       gtk? ( x11-libs/gtk+:2
+               x11-libs/wxGTK:3.0 )"
+DEPEND="${RDEPEND}
+       dev-util/waf
+       virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.8.0-wxGTK3.patch
+       "${FILESDIR}"/${PN}-2.8.0-no-ldconfig.patch
+       "${FILESDIR}"/${PN}-2.8.0-desktop.patch
+       "${FILESDIR}"/${PN}-2.10.2-respect-cxxflags.patch
+       )
+
+src_prepare() {
+       rm -v waf
+       export WAF_BINARY=${EROOT}usr/bin/waf
+       if [ -z "${PYTHONPATH}" ] ; then
+               export PYTHONPATH="${S}"
+       else
+               export PYTHONPATH="${S}:${PYTHONPATH}"
+       fi
+
+       ewarn "Some tests failing due missing files/certs are disabled."
+       sed \
+               -e '/4k_test.cc/d' \
+               -e '/audio_analysis_test.cc/d' \
+               -e '/audio_decoder_test.cc/d' \
+               -e '/audio_processor_test.cc/d' \
+               -e '/black_fill_test.cc/d' \
+               -e '/client_server_test.cc/d' \
+               -e '/dcp_subtitle_test.cc/d' \
+               -e '/ffmpeg_decoder_sequential_test.cc/d' \
+               -e '/file_naming_test.cc/d' \
+               -e '/import_dcp_test.cc/d' \
+               -e '/interrupt_encoder_test.cc/d' \
+               -e '/j2k_bandwidth_test.cc/d' \
+               -e '/recover_test.cc/d' \
+               -e '/reels_test.cc/d' \
+               -e '/render_subtitles_test.cc/d' \
+               -e '/repeat_frame_test.cc/d' \
+               -e '/scaling_test.cc/d' \
+               -e '/skip_frame_test.cc/d' \
+               -e '/srt_subtitle_test.cc/d' \
+               -e '/ssa_subtitle_test.cc/d' \
+               -e '/vf_test.cc/d' \
+               -e '/video_mxf_content_test.cc/d' \
+        -e '/film_metadata_test.cc/d' \
+               -i test/wscript || die
+
+       default
+}
+
+src_configure() {
+       waf-utils_src_configure $(usex gtk "" "--disable-gui")
+}
+
+src_test() {
+       ./run/tests || die
+}
diff --git a/media-video/dcpomatic/dcpomatic-2.9.0.ebuild b/media-video/dcpomatic/dcpomatic-2.9.0.ebuild
new file mode 100644 (file)
index 0000000..80f5ab3
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils wxwidgets
+
+DESCRIPTION="create Digital Cinema Packages (DCPs) from videos, images and sound files"
+HOMEPAGE="http://dcpomatic.com/"
+SRC_URI="http://${PN}.com/downloads/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gtk"
+
+RDEPEND="dev-cpp/cairomm
+       dev-cpp/glibmm:2
+       dev-cpp/libxmlpp:2.6
+       dev-cpp/pangomm:1.4
+       dev-libs/boost
+       dev-libs/glib:2
+       dev-libs/icu
+       dev-libs/libcxml
+       dev-libs/libzip
+       dev-libs/openssl:0
+       || ( media-gfx/graphicsmagick media-gfx/imagemagick )
+       media-libs/fontconfig:1.0
+       media-libs/libdcp:1.0
+       media-libs/libsamplerate
+       media-libs/libsndfile
+       media-libs/libsub:1.0
+       >=media-video/ffmpeg-3
+       <media-video/ffmpeg-3.2.4
+       net-libs/libssh
+       net-misc/curl
+       gtk? ( x11-libs/gtk+:2
+               x11-libs/wxGTK:3.0 )"
+DEPEND="${RDEPEND}
+       dev-util/waf
+       virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.8.0-wxGTK3.patch
+       "${FILESDIR}"/${PN}-2.8.0-no-ldconfig.patch
+       "${FILESDIR}"/${PN}-2.8.0-desktop.patch
+       )
+
+src_prepare() {
+       rm -v waf
+       export WAF_BINARY=${EROOT}usr/bin/waf
+       if [ -z "${PYTHONPATH}" ] ; then
+               export PYTHONPATH="${S}"
+       else
+               export PYTHONPATH="${S}:${PYTHONPATH}"
+       fi
+
+       default
+}
+
+src_configure() {
+       waf-utils_src_configure $(usex gtk "" "--disable-gui")
+}
diff --git a/media-video/dcpomatic/files/dcpomatic-2.10.2-respect-cxxflags.patch b/media-video/dcpomatic/files/dcpomatic-2.10.2-respect-cxxflags.patch
new file mode 100644 (file)
index 0000000..330dfd0
--- /dev/null
@@ -0,0 +1,13 @@
+--- dcpomatic-2.10.2/wscript
++++ dcpomatic-2.10.2/wscript
+@@ -89,9 +89,7 @@
+     have_c11 = int(gcc[0]) >= 4 and int(gcc[1]) >= 8 and int(gcc[2]) >= 1
+     if conf.options.enable_debug:
+-        conf.env.append_value('CXXFLAGS', ['-g', '-DDCPOMATIC_DEBUG', '-fno-omit-frame-pointer'])
+-    else:
+-        conf.env.append_value('CXXFLAGS', '-O2')
++        conf.env.append_value('CXXFLAGS', ['-DDCPOMATIC_DEBUG', '-fno-omit-frame-pointer'])
+     #
+     # Windows/Linux/OS X specific
diff --git a/media-video/dcpomatic/files/dcpomatic-2.8.0-desktop.patch b/media-video/dcpomatic/files/dcpomatic-2.8.0-desktop.patch
new file mode 100644 (file)
index 0000000..615a998
--- /dev/null
@@ -0,0 +1,32 @@
+--- dcpomatic-2.8.0/platform/linux/dcpomatic.desktop.in
++++ dcpomatic-2.8.0/platform/linux/dcpomatic.desktop.in
+@@ -7,4 +7,4 @@
+ Name=DCP-o-matic 2
+ Icon=dcpomatic2
+ Comment=DCP generator
+-Categories=AudioVideo;Video
++Categories=AudioVideo;Video;
+--- dcpomatic-2.8.0/platform/linux/dcpomatic_server.desktop.in
++++ dcpomatic-2.8.0/platform/linux/dcpomatic_server.desktop.in
+@@ -7,4 +7,4 @@
+ Name=DCP-o-matic 2 Encode Server
+ Icon=dcpomatic2_server
+ Comment=DCP generator
+-Categories=AudioVideo;Video
++Categories=AudioVideo;Video;
+--- dcpomatic-2.8.0/platform/linux/dcpomatic_kdm.desktop.in
++++ dcpomatic-2.8.0/platform/linux/dcpomatic_kdm.desktop.in
+@@ -7,4 +7,4 @@
+ Name=DCP-o-matic 2 KDM Creator
+ Icon=dcpomatic2_kdm
+ Comment=DCP generator
+-Categories=AudioVideo;Video
++Categories=AudioVideo;Video;
+--- dcpomatic-2.8.0/platform/linux/dcpomatic_batch.desktop.in
++++ dcpomatic-2.8.0/platform/linux/dcpomatic_batch.desktop.in
+@@ -7,4 +7,4 @@
+ Name=DCP-o-matic 2 Batch Converter
+ Icon=dcpomatic2_batch
+ Comment=DCP generator
+-Categories=AudioVideo;Video
++Categories=AudioVideo;Video;
diff --git a/media-video/dcpomatic/files/dcpomatic-2.8.0-no-ldconfig.patch b/media-video/dcpomatic/files/dcpomatic-2.8.0-no-ldconfig.patch
new file mode 100644 (file)
index 0000000..106e239
--- /dev/null
@@ -0,0 +1,12 @@
+--- dcpomatic-2.8.0/wscript
++++ dcpomatic-2.8.0/wscript
+@@ -503,8 +503,7 @@
+         sys.exit(-1)
+ def post(ctx):
+-    if ctx.cmd == 'install':
+-        ctx.exec_command('/sbin/ldconfig')
++    pass
+ def pot(bld):
+     bld.recurse('src')
diff --git a/media-video/dcpomatic/files/dcpomatic-2.8.0-wxGTK3.patch b/media-video/dcpomatic/files/dcpomatic-2.8.0-wxGTK3.patch
new file mode 100644 (file)
index 0000000..9d85ad5
--- /dev/null
@@ -0,0 +1,13 @@
+--- dcpomatic-2.8.0/src/wx/wscript
++++ dcpomatic-2.8.0/src/wx/wscript
+@@ -103,8 +103,8 @@
+ def configure(conf):
+     try:
+-        wx_config = 'wx-config-3.0-gtk2'
+-        conf.check_cfg(msg='Checking for wxWidgets using wx-config-3.0-gtk2',
++        wx_config = 'wx-config-3.0'
++        conf.check_cfg(msg='Checking for wxWidgets using wx-config-3.0',
+                        package='',
+                        path=wx_config,
+                        args='--cppflags --cxxflags --libs std,richtext',
diff --git a/media-video/dcpomatic/metadata.xml b/media-video/dcpomatic/metadata.xml
new file mode 100644 (file)
index 0000000..bc4c75f
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+<longdescription lang="en">
+DCP-o-matic is a free, open-source program to create Digital Cinema Packages (DCPs) from videos, images, sound and subtitle files. You can use it to make content for playback on DCI-compliant cinema projectors.
+
+It can take files in many different formats, including MP4, Apple ProRes, MOV, AVI, VOB (from DVDs), M2TS (from Blu-Ray), WMV, MKV, JPEG, PNG, TIFF and lots of others.
+</longdescription>
+</pkgmetadata>