mail-client/roundcube: Version bump, security, and bug fixes
authorAaron W. Swenson <titanofold@gentoo.org>
Wed, 9 Dec 2015 12:44:37 +0000 (07:44 -0500)
committerAaron W. Swenson <titanofold@gentoo.org>
Wed, 9 Dec 2015 12:44:37 +0000 (07:44 -0500)
Added two use flags controlling optional dependencies to support the
enigma and and sieverules plugins.

Added REQUIRED_USE as one of postgres, mysql, or sqlite must be
enabled. Rouncube requires a database to operate. As the ebuild uses
this now, removed the default enable on the mysql USE flag.

Added POST-UPGRADE.txt which is just a shortened version of the
UPGRADE text from upstream.

Dropped arm and ppc64 keywords as one dependency,
dev-php/PEAR-Net_LDAP2, currently lacks matching keywords for those
architectures.

Bug: 541172, 545096, 524192, 564476, 565204, 53284

Package-Manager: portage-2.2.20.1

mail-client/roundcube/Manifest
mail-client/roundcube/files/POST-UPGRADE.txt [new file with mode: 0644]
mail-client/roundcube/metadata.xml
mail-client/roundcube/roundcube-1.1.3.ebuild [new file with mode: 0644]

index 1875e64e8c52ad9159bb15d24b89e113c3ddaaa8..0dd26c6c7289ae79a83cbd729780997f2ef3afc9 100644 (file)
@@ -1,2 +1,3 @@
 DIST roundcubemail-1.0.5.tar.gz 4056852 SHA256 22af84480f2c543884b17c9b0196ed105d2ea7f429bfcc34a6fb7c96dd712792 SHA512 28016a8b05bdf4777486c63d95a91a22022006252e61e4e93320d81448cbc630ed5a04a1388d8576a40617d8e0630b90290341fcd3fed4f5080ab250fb568c6c WHIRLPOOL f0e48173e0fe07a8f3a00a49ad1091c33f76dbeb153941e32c35684f4eb41e04f805f63ec9623e3664c165c6e88407db3665f1e60a01c2076a3c60bc96c4a122
 DIST roundcubemail-1.0.6.tar.gz 4057804 SHA256 76e600183c91fa598823bb97208f81485c73f354ea05f4e82d56e91003e0df49 SHA512 1aa2f652fe88c3fa22d1181105733a6bf0bdd5439b7abc051a4b00030310c923936487e6aa5d5f62179fae010c79b818d6b5e37afca749dcf1738be8930c7709 WHIRLPOOL e9581f4707daf1bdf9c11316ed60e457a367ba94ff46b92e72fea38eec09df86858f5af55ce4626016fe54552dbea155466fed62fe5a27539b46e89d1714f9b4
+DIST roundcubemail-1.1.3.tar.gz 3208502 SHA256 343d3981067da44e9f3eaee94c2c86247a4341ebe7268bba8bff67d9906aaf34 SHA512 be5d64a8d52aa623de614bc1b137ae2f74250de050de086a510114121bcb760b973f8319884395827f324371542b741b80054b90031d8814752bb018dcda2096 WHIRLPOOL 9bdf316b27153c0ad5eacbeb4d4ecf4dd958b430d2ea3115ba04b67db9d1004482cb57046faa031b93fc0d7b18c93c081e7501cbb7d485383c7d611a1af1fcae
diff --git a/mail-client/roundcube/files/POST-UPGRADE.txt b/mail-client/roundcube/files/POST-UPGRADE.txt
new file mode 100644 (file)
index 0000000..8c2296b
--- /dev/null
@@ -0,0 +1,17 @@
+Post-Upgrade Activities
+-----------------------
+1. Check .htaccess settings (some php settings could become required)
+2. If you're using build-in addressbook, run indexing script
+   /bin/indexcontacts.sh.
+3. When upgrading from version older than 0.6-beta you should make sure
+   your folder settings contain namespace prefix. For example Courier users
+   should add INBOX. prefix to folder names in main configuration file.
+4. Check system requirements in INSTALL file.
+
+SQLite database upgrade
+-----------------------
+Versions older than 0.9 were supporting SQLite v2 only. Newer versions require
+database in v3 format. The best what you can do is to convert database file
+to the new format using command line tools:
+
+sqlite OLD.DB .dump | sqlite3 NEW.DB
index 1197f8861880fea63244d349a44282a6041501f6..4cb349a08b2c2352ac1833dd7d0f6bf63ac5a9e4 100644 (file)
@@ -2,7 +2,24 @@
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
        <herd>web-apps</herd>
+       <maintainer>
+               <email>titanofold@gentoo.org</email>
+               <name>Aaron W. Swenson</name>
+       </maintainer>
        <upstream>
                <remote-id type="sourceforge">roundcubemail</remote-id>
        </upstream>
+       <use>
+               <flag name="enigma">
+                       Add dependencies to support server-side GnuPG signing
+                       and/or encryption through the enigma plugin
+               </flag>
+               <flag name="managesieve">
+                       Add dependencies to support the sieverules plugin
+               </flag>
+               <flag name="ldap">
+                       Add dependencies to support connecting to an LDAP address
+                       book server
+               </flag>
+       </use>
 </pkgmetadata>
diff --git a/mail-client/roundcube/roundcube-1.1.3.ebuild b/mail-client/roundcube/roundcube-1.1.3.ebuild
new file mode 100644 (file)
index 0000000..e940211
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_P=${MY_PN}-${PV/_/-}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+
+IUSE="enigma ldap managesieve mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+       ${DEPEND}
+       >=dev-lang/php-5.3.7[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,sqlite?,ssl?,unicode,xml]
+       >=dev-php/PEAR-Auth_SASL-1.0.6
+       >=dev-php/PEAR-Mail_Mime-1.8.9
+       >=dev-php/PEAR-Mail_mimeDecode-1.5.5
+       >=dev-php/PEAR-Net_IDNA2-0.1.1
+       >=dev-php/PEAR-Net_SMTP-1.6.2
+       virtual/httpd-php
+       enigma? ( >=dev-php/PEAR-Crypt_GPG-1.2.0 app-crypt/gnupg )
+       ldap? ( >=dev-php/PEAR-Net_LDAP2-2.0.12 )
+       managesieve? ( >=dev-php/PEAR-Net_Sieve-1.3.2 )
+       mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
+       spell? ( dev-lang/php[curl,spell] )
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+       webapp_src_preinst
+       dodoc CHANGELOG INSTALL README.md UPGRADING
+
+       insinto "${MY_HTDOCSDIR}"
+       doins -r [[:lower:]]* SQL
+       doins .htaccess
+
+       webapp_serverowned "${MY_HTDOCSDIR}"/logs
+       webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+       webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+       webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
+       webapp_src_install
+}
+
+pkg_postinst() {
+       webapp_pkg_postinst
+
+       ewarn
+       ewarn "When upgrading from <= 0.9, note that the old configuration files"
+       ewarn "named main.inc.php and db.inc.php are deprecated and should be"
+       ewarn "replaced with one single config.inc.php file."
+       ewarn
+       ewarn "Run the ./bin/update.sh script to convert those"
+       ewarn "or manually merge the files."
+       ewarn
+       ewarn "The new config.inc.php should only contain options that"
+       ewarn "differ from the ones listed in defaults.inc.php."
+       ewarn
+}