dev-python/oslo*: fixing seds and prepare statements
authorMatthew Thode <mthode@mthode.org>
Tue, 1 Sep 2015 15:35:40 +0000 (10:35 -0500)
committerMatthew Thode <mthode@mthode.org>
Tue, 1 Sep 2015 15:35:40 +0000 (10:35 -0500)
dev-python/debtcollector/debtcollector-0.7.0.ebuild
dev-python/oslo-config/oslo-config-2.3.0.ebuild
dev-python/oslotest/oslotest-1.10.0.ebuild

index fae6fae78057ca66bdc53daac69a7a342c92cb09..7baebb5128375288dd36739be16a1a0088745f08 100644 (file)
@@ -44,8 +44,12 @@ RDEPEND="
        >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
 "
 
-python_compile_all() {
+python_prepare_all() {
        sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
        use doc && esetup.py build_sphinx
 }
 
index 3d4c587e49695d0c2775d9baad16d340c4a8fd19..b275cba270068c2e34874b705fb9ceb3095a6a8d 100644 (file)
@@ -47,9 +47,10 @@ RDEPEND="
 "
 
 python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt
-       sed -i '/^argparse/d' requirements.txt
+       sed -i '/^hacking/d' test-requirements.txt || die
+       sed -i '/^argparse/d' requirements.txt || die
        use doc && esetup.py build_sphinx
+       distutils-r1_python_prepare_all
 }
 
 python_test() {
index 7af4e9bd8ee50374aec57c70450a532b977bba61..a5967d08a10aef97ddb5a14cf221e9bf6c8f31ae 100644 (file)
@@ -40,7 +40,7 @@ RDEPEND="
 "
 
 python_prepare() {
-       sed -i '/^hacking/d' test-requirements.txt
+       sed -i '/^hacking/d' test-requirements.txt || die
        distutils-r1_python_prepare
 }