media-libs/hamlib: Fix build error with -Werror=format-security
authorThomas Beierlein <tomjbe@gentoo.org>
Wed, 25 Mar 2020 14:14:44 +0000 (15:14 +0100)
committerThomas Beierlein <tomjbe@gentoo.org>
Wed, 25 Mar 2020 14:15:10 +0000 (15:15 +0100)
Closes: https://bugs.gentoo.org/714682
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
media-libs/hamlib/files/hamlib-3.3-format-security.patch [new file with mode: 0644]
media-libs/hamlib/hamlib-3.3.ebuild

diff --git a/media-libs/hamlib/files/hamlib-3.3-format-security.patch b/media-libs/hamlib/files/hamlib-3.3-format-security.patch
new file mode 100644 (file)
index 0000000..bbf2de1
--- /dev/null
@@ -0,0 +1,14 @@
+# Fixes build error with format-securety (bug #714682)
+diff --git a/tests/rotctl_parse.c b/tests/rotctl_parse.c
+index 44308cc..aab1300 100644
+--- a/tests/rotctl_parse.c
++++ b/tests/rotctl_parse.c
+@@ -1009,7 +1009,7 @@ int rotctl_parse(ROT *my_rot, FILE *fin, FILE *fout, char *argv[], int argc)
+             /* The starting position of the source string is the first
+              * character past the initial '\'.
+              */
+-            snprintf(cmd_name, sizeof(cmd_name), parsed_input[0] + 1);
++            snprintf(cmd_name, sizeof(cmd_name), "%s", parsed_input[0] + 1);
+             /* Sanity check as valid multiple character commands consist of
+              * alpha-numeric characters and the underscore ('_') character.
index 7a23ca37f1be3d442c5c698d6becfad4cd06018b..2cde4b103be4b54c38427fbe2062e3ea7f122fd2 100644 (file)
@@ -34,6 +34,8 @@ DEPEND=" ${RDEPEND}
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
+PATCHES=( "${FILESDIR}"/hamlib-3.3-format-security.patch )
+
 DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer TODO)
 
 pkg_setup() {
@@ -57,6 +59,8 @@ src_prepare() {
 
        eautoreconf
 
+       eapply "${PATCHES}"
+
        eapply_user
 }