dev-ruby/tty-prompt: initial import of 0.19.0
authorHans de Graaff <graaff@gentoo.org>
Sun, 16 Jun 2019 06:15:37 +0000 (08:15 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 16 Jun 2019 06:37:56 +0000 (08:37 +0200)
Dependency for forthcoming dev-ruby/tty-file

Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-ruby/tty-prompt/Manifest [new file with mode: 0644]
dev-ruby/tty-prompt/metadata.xml [new file with mode: 0644]
dev-ruby/tty-prompt/tty-prompt-0.19.0.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/tty-prompt/Manifest b/dev-ruby/tty-prompt/Manifest
new file mode 100644 (file)
index 0000000..1794946
--- /dev/null
@@ -0,0 +1 @@
+DIST tty-prompt-0.19.0.gem 71680 BLAKE2B 67da3c428fa5ab602fa4735d06115ba5bab53f06d43109fa06810e538cafae5486767f41927fc77616e608278a0f955659734704c9536b40e87682e6f0e5718b SHA512 958263a7b3b7cfbac2877d81878b324fe53bc258be36749597f959085643e50247651bf48fceff4bf1098b68cf47dae68f30173e45585bfdbf7126959387427a
diff --git a/dev-ruby/tty-prompt/metadata.xml b/dev-ruby/tty-prompt/metadata.xml
new file mode 100644 (file)
index 0000000..a2602b5
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>ruby@gentoo.org</email>
+               <name>Gentoo Ruby Project</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">piotrmurach/tty-prompt</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tty-prompt/tty-prompt-0.19.0.ebuild b/dev-ruby/tty-prompt/tty-prompt-0.19.0.ebuild
new file mode 100644 (file)
index 0000000..dc49d8a
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A beautiful and powerful interactive command line prompt"
+HOMEPAGE="https://github.com/piotrmurach/tty-prompt"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+       echo '-rspec_helper' > .rspec || die
+}