sys-apps/proot-5.1.0-r2: remove support for static and live builds
authorSergey Popov <pinkbyte@gentoo.org>
Mon, 18 May 2020 15:36:47 +0000 (18:36 +0300)
committerSergey Popov <pinkbyte@gentoo.org>
Mon, 18 May 2020 15:37:36 +0000 (18:37 +0300)
They are effectively not working since the introduction

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
sys-apps/proot/proot-5.1.0-r2.ebuild

index ac2eea07dbf70194b872ed70a7de4b345041cc87..32cc490743953ed259cef41c701369a3d2cb84cc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -6,20 +6,15 @@ MY_PN="PRoot"
 
 inherit eutils toolchain-funcs
 
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/proot-me/${MY_PN}.git"
-       inherit git-r3
-else
-       SRC_URI="https://github.com/proot-me/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-fi
+SRC_URI="https://github.com/proot-me/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
 
 DESCRIPTION="User-space implementation of chroot, mount --bind, and binfmt_misc"
 HOMEPAGE="https://proot-me.github.io"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="care static test"
+IUSE="care test"
 
 RDEPEND="care? ( app-arch/libarchive:0= )
         sys-libs/talloc"
@@ -38,11 +33,6 @@ PATCHES=(
        "${FILESDIR}/${PN}-5.1.0-loader.patch"
 )
 
-src_prepare() {
-       default
-       use static && append-ldflags -static
-}
-
 src_compile() {
        # build the proot and care targets
        emake -C src V=1 \