sys-libs/libcap-ng: bump to 0.7.9
authorMike Gilbert <floppym@gentoo.org>
Thu, 8 Feb 2018 16:36:11 +0000 (11:36 -0500)
committerMike Gilbert <floppym@gentoo.org>
Thu, 8 Feb 2018 16:36:11 +0000 (11:36 -0500)
Package-Manager: Portage-2.3.24, Repoman-2.3.6_p81

sys-libs/libcap-ng/Manifest
sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild [new file with mode: 0644]

index 277155c33a5a43595a945d0d7d570a86ddb426fb..dda87749b4905f68adf413e379e6b4c9dc3dd133 100644 (file)
@@ -1 +1,2 @@
 DIST libcap-ng-0.7.8.tar.gz 447946 BLAKE2B a26af2dcdd1af26cf03ca668dc95eed7bc1d0344729031497f46bba865bcb23ded2f1ea2ca5cb500b9419bbbd7ed75501921485257a3c8930d156a94e0a2c1c1 SHA512 c32a4c5780c183b13611615abe9061221fd8987188b08828d1617cdaee338ad8de67b3430aa83bde60128efc76449a688546bfbf697f0847b6a835cb1a868756
+DIST libcap-ng-0.7.9.tar.gz 449038 BLAKE2B 3f84e5078d5d443cb61358c49405e4f16ff82a56e1c96d5127b522613b1b5c56a566a01b14b40055eca85f13b37f3d795248a506c54ac4612ab184a94addc365 SHA512 095edabaf76a943aab0645b843b14e20b1733ba1d47a8e34d82f6586ca9a1512ba2677d232b13dd3900b913837401bb58bf74481970e967ba19041959dc43259
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild
new file mode 100644 (file)
index 0000000..850239d
--- /dev/null
@@ -0,0 +1,86 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit flag-o-matic python-r1
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="https://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="https://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+       sys-kernel/linux-headers
+       python? ( >=dev-lang/swig-2 )"
+
+src_configure() {
+       use sparc && replace-flags -O? -O0
+
+       local ECONF_SOURCE=${S}
+
+       local myconf=(
+               $(use_enable static-libs static)
+       )
+
+       local pythonconf=( --without-python --without-python3 )
+
+       # set up python bindings build(s)
+       if use python ; then
+               setup_python_flags_configure() {
+                       if python_is_python3; then
+                               pythonconf=( --without-python --with-python3 )
+                       else
+                               pythonconf=( --with-python --without-python3 )
+                               local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+                       fi
+                       run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
+               }
+
+               python_foreach_impl setup_python_flags_configure
+       else
+               local BUILD_DIR=${WORKDIR}/build
+               run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
+       fi
+}
+
+src_compile() {
+       if use python; then
+               python_foreach_impl run_in_build_dir emake
+       else
+               local BUILD_DIR=${WORKDIR}/build
+               emake -C "${BUILD_DIR}"
+       fi
+}
+
+src_test() {
+       if [[ "${EUID}" -eq 0 ]]; then
+               ewarn "Skipping tests due to root permissions."
+               return
+       fi
+
+       if use python; then
+               python_foreach_impl run_in_build_dir emake check
+       else
+               local BUILD_DIR=${WORKDIR}/build
+               emake -C "${BUILD_DIR}" check
+       fi
+}
+
+src_install() {
+       if use python; then
+               python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+       else
+               local BUILD_DIR=${WORKDIR}/build
+               emake -C "${BUILD_DIR}" DESTDIR="${D}" install
+       fi
+       find "${ED}" -name '*.la' -delete || die
+}