x11-plugins/wmcms: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 29 Mar 2020 11:08:19 +0000 (13:08 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 29 Mar 2020 11:35:23 +0000 (13:35 +0200)
Latest libdockapp revbump now defines a global variable as extern

Bug: https://bugs.gentoo.org/715260
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmcms/files/wmcms-0.3.5-fno-common.patch [new file with mode: 0644]
x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild [moved from x11-plugins/wmcms/wmcms-0.3.5-r3.ebuild with 78% similarity]

diff --git a/x11-plugins/wmcms/files/wmcms-0.3.5-fno-common.patch b/x11-plugins/wmcms/files/wmcms-0.3.5-fno-common.patch
new file mode 100644 (file)
index 0000000..3b06076
--- /dev/null
@@ -0,0 +1,11 @@
+diff -Naur wmcms-0.3.5.orig/wmcms.c wmcms-0.3.5/wmcms.c
+--- wmcms-0.3.5.orig/wmcms.c   2001-09-24 00:57:06.000000000 +0200
++++ wmcms-0.3.5/wmcms.c        2020-03-29 13:04:56.465162877 +0200
+@@ -28,6 +28,7 @@
+ GC gc;
+ Pixmap pixmap;
+ Pixmap backdrop;
++Display *display;
+ int advanced;
+ int up;
similarity index 78%
rename from x11-plugins/wmcms/wmcms-0.3.5-r3.ebuild
rename to x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild
index 3c00c746459ea4b67c5ee081b385c980e6b0aa60..cddbcd6bd97d809985b27902e32191a1bc9bf5ab 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -11,11 +11,15 @@ LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
 
-DEPEND=">=x11-libs/libdockapp-0.7:="
+DEPEND=">=x11-libs/libdockapp-0.7-r1:="
+
+PATCHES=(
+       "${FILESDIR}"/${P}-s4t4n.patch
+       "${FILESDIR}"/${P}-fno-common.patch
+)
 
 src_prepare() {
        default
-       eapply "${FILESDIR}"/wmcms-0.3.5-s4t4n.patch
 
        # Respect LDFLAGS, see bug #335031
        sed -e 's/ -o wmcms/ ${LDFLAGS} -o wmcms/' -i Makefile || die