dev-util/buildbot: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 10:05:30 +0000 (11:05 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 10:13:49 +0000 (11:13 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/buildbot/Manifest
dev-util/buildbot/buildbot-0.8.12-r3.ebuild [deleted file]

index 147a94705ef9b8ef3faff4bdf0943ba13fddbe6f..945e3fa1b8abda864d2174cdb260ac10a860ceda 100644 (file)
@@ -1,4 +1,3 @@
-DIST buildbot-0.8.12.tar.gz 4834352 BLAKE2B 16d06d6ccbbb90581471cf1727cc9cdd556ab1c0fa1433bbe76475513a7482619b05c28038e956e8724b99a806aec371961302914567fd36caccfe342daa6aaa SHA512 18c5144132fb033f3581d3c494d5e8ff35d3e8b1548764452ce9ae543d710e58a2c6e3e8e46a0ef237804f9a6a45485890ae4616ab655fb00d4ccf328d6f6645
 DIST buildbot-0.9.12.tar.gz 3057832 BLAKE2B 8e1748739bacc3c884f353b2a1c798575e3ce5f451a1711ecf88a7c7e517da86d2e791748d31468a2bb07369022e96cb568518b7a8ce1d9e1cece0b6ab77eec8 SHA512 62459918267297b31b2a6416f72794c7a4ebdcb60de04ece1681f6b8be9debf161716cc70ad843fd468b23e02c521c0a0783a5a1e119d75648e107691d6b908d
 DIST buildbot-1.1.2.tar.gz 3101168 BLAKE2B 35ec56440014015850a69324d475c4ca9555ad90da85b26a7a43eca74f08361137021aec72ddca37cbb24f21519ebf45948e66214291f356b4a1fbada7c0b3b8 SHA512 14c28d6fae18a10d89d41509635188d881ac76e7b61758481a9afbb22eb384d7ab5080383242e5850af13bfe46877985a91036270c3c4fbf01eafee5b7699815
 DIST buildbot-1.3.0.tar.gz 3119185 BLAKE2B d366b83baad7e865481535a2462ceb222aadce6c90a6229e82a72bf86518b8ebb0624d8ac8b64867783d58b6e9033b942a1ccd31fd6664a2b527eac9f11ab852 SHA512 e5ecf3eafe428a188c2410d270ee9bd5afc39122e62d35747288cf85347368ab4a94190b4ff6fe687269dc19cc7b91d33be8d3e3b637741e421a2cbd83572830
diff --git a/dev-util/buildbot/buildbot-0.8.12-r3.ebuild b/dev-util/buildbot/buildbot-0.8.12-r3.ebuild
deleted file mode 100644 (file)
index f4f29f9..0000000
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 readme.gentoo systemd user
-
-MY_PV="${PV/_p/p}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="BuildBot build automation system"
-HOMEPAGE="http://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="doc examples irc mail manhole test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/jinja-2.1[${PYTHON_USEDEP}]
-       dev-python/twisted-core[${PYTHON_USEDEP}]
-       dev-python/twisted-web[${PYTHON_USEDEP}]
-       <=dev-python/sqlalchemy-0.7.10-r999[${PYTHON_USEDEP}]
-       ~dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
-       irc? ( dev-python/twisted-words[${PYTHON_USEDEP}] )
-       mail? ( dev-python/twisted-mail[${PYTHON_USEDEP}] )
-       manhole? ( dev-python/twisted-conch[${PYTHON_USEDEP}] )"
-DEPEND="${DEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/twisted-mail[${PYTHON_USEDEP}]
-               dev-python/twisted-web[${PYTHON_USEDEP}]
-               dev-python/twisted-words[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
-       enewuser buildbot
-
-       DOC_CONTENTS="The \"buildbot\" user and the \"buildmaster\" init script has been added
-               to support starting buildbot through Gentoo's init system. To use this,
-               execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
-               The scripts can run as a different user if desired."
-}
-
-src_compile() {
-       distutils-r1_src_compile
-
-       if use doc; then
-               einfo "Generation of documentation"
-               pushd docs > /dev/null
-               #'man' target is currently broken
-               emake html
-               popd > /dev/null
-       fi
-}
-
-src_install() {
-       distutils-r1_src_install
-
-       doman docs/buildbot.1
-
-       if use doc; then
-               dohtml -r docs/_build/html/
-               # TODO: install man pages
-       fi
-
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r contrib docs/examples
-       fi
-
-       newconfd "${FILESDIR}/buildmaster.confd" buildmaster
-       newinitd "${FILESDIR}/buildmaster.initd" buildmaster
-       systemd_dounit "${FILESDIR}/buildmaster.target"
-       systemd_newunit "${FILESDIR}/buildmaster_at.service" "buildmaster@.service"
-       systemd_install_serviced "${FILESDIR}/buildmaster_at.service.conf" "buildmaster@.service"
-
-       readme.gentoo_create_doc
-}
-
-pkg_postinst() {
-       readme.gentoo_print_elog
-
-       if [[ -n ${REPLACING_VERSIONS} ]]; then
-               ewarn
-               ewarn "Starting with buildbot-0.8.12-r2, more than one instance of buildmaster"
-               ewarn "can be run simultaneously. Note that \"BASEDIR\" in the buildbot configuration file"
-               ewarn "is now the common base directory for all instances. If you are migrating from an older"
-               ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
-               ewarn "The name of the subdirectory corresponds to the name of the buildmaster instance."
-               ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
-               ewarn "    ln --symbolic --relative /etc/init.d/buildmaster /etc/init.d/buildmaster.myinstance"
-               ewarn "    rc-update add buildmaster.myinstance default"
-               ewarn "    /etc/init.d/buildmaster.myinstance start"
-               ewarn "Systems using systemd can do the following:"
-               ewarn "    systemctl enable buildmaster@myinstance.service"
-               ewarn "    systemctl enable buildmaster.target"
-               ewarn "    systemctl start buildmaster.target"
-               elog
-               elog "Upstream recommends the following when upgrading:"
-               elog "Each time you install a new version of Buildbot, you should run the"
-               elog "\"buildbot upgrade-master\" command on each of your pre-existing build masters."
-               elog "This will add files and fix (or at least detect) incompatibilities between"
-               elog "your old config and the new code."
-       fi
-       elog
-       elog "In order to create a new instance of buildmaster, execute:"
-       elog "    emerge --config =${CATEGORY}/${PF}"
-}
-
-pkg_config() {
-       local buildmaster_path="/var/lib/buildmaster"
-       einfo "This will prepare a new buildmaster instance in ${buildmaster_path}."
-       einfo "Press Control-C to abort."
-
-       einfo "Enter the name for the new instance: "
-       read instance_name
-       [[ -z "${instance_name}" ]] && die "Invalid instance name"
-
-       local instance_path="${buildmaster_path}/${instance_name}"
-       if [[ -e "${instance_path}" ]]; then
-               eerror "The instance with the specified name already exists:"
-               eerror "${instance_path}"
-               die "Instance already exists"
-       fi
-
-       local buildbot="/usr/bin/buildbot"
-       if [[ ! -d "${buildmaster_path}" ]]; then
-               mkdir --parents "${buildmaster_path}" || die "Unable to create directory ${buildmaster_path}"
-       fi
-       "${buildbot}" create-master "${instance_path}" &>/dev/null || die "Creating instance failed"
-       chown --recursive buildbot "${instance_path}" || die "Setting permissions for instance failed"
-       mv "${instance_path}/master.cfg.sample" "${instance_path}/master.cfg" \
-               || die "Moving sample configuration failed"
-       ln --symbolic --relative "/etc/init.d/buildmaster" "/etc/init.d/buildmaster.${instance_name}" \
-               || die "Unable to create link to init file"
-
-       einfo "Successfully created a buildmaster instance at ${instance_path}."
-       einfo "To change the default settings edit the master.cfg file in this directory."
-}