old
authorMike Frysinger <vapier@gentoo.org>
Sat, 11 Nov 2006 09:18:17 +0000 (09:18 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 11 Nov 2006 09:18:17 +0000 (09:18 +0000)
sys-libs/com_err/com_err-1.38.ebuild [deleted file]
sys-libs/com_err/files/com_err-1.37-makefile.patch [deleted file]
sys-libs/com_err/files/digest-com_err-1.38 [deleted file]

diff --git a/sys-libs/com_err/com_err-1.38.ebuild b/sys-libs/com_err/com_err-1.38.ebuild
deleted file mode 100644 (file)
index 672f090..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.38.ebuild,v 1.18 2006/01/07 00:26:12 swegener Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="common error display library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls"
-
-RDEPEND=""
-DEPEND="nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}"/${PN}-1.37-makefile.patch
-}
-
-src_compile() {
-       export LDCONFIG=/bin/true
-       export CC=$(tc-getCC)
-       export STRIP=/bin/true
-
-       # We want to use the "bsd" libraries while building on Darwin, but while
-       # building on other Gentoo/*BSD we prefer elf-naming scheme.
-       local libtype
-       case ${CHOST} in
-               *-darwin*) libtype=bsd;;
-               *)         libtype=elf;;
-       esac
-
-       mkdir -p lib/{blkid,e2p,et,ext2fs,ss,uuid}/{checker,elfshared,pic,profiled} #102412
-       econf \
-               --enable-${libtype}-shlibs \
-               --with-ldopts="${LDFLAGS}" \
-               $(use_enable nls) \
-               || die
-       emake -C lib/et || die
-}
-
-src_test() {
-       make -C lib/et check || die "make check failed"
-}
-
-src_install() {
-       export LDCONFIG=/bin/true
-       export CC=$(tc-getCC)
-       export STRIP=/bin/true
-
-       make -C lib/et DESTDIR="${D}" install || die
-       dosed '/^ET_DIR=/s:=.*:=/usr/share/et:' /usr/bin/compile_et
-       dosym et/com_err.h /usr/include/com_err.h
-
-       dolib.a lib/libcom_err.a || die "dolib.a"
-       if [[ ${USERLAND} == "Darwin" ]] ; then
-               dosym /usr/$(get_libdir)/libcom_err.*.dylib /usr/$(get_libdir)/libcom_err.dylib || die
-       else
-               dodir /$(get_libdir)
-               mv "${D}"/usr/$(get_libdir)/*$(get_libname)* "${D}"/$(get_libdir)/ || die "move .so"
-               gen_usr_ldscript libcom_err.so
-       fi
-}
-
-pkg_postinst() {
-       echo
-       einfo "PLEASE PLEASE take note of this"
-       einfo "Please make *sure* to run revdep-rebuild now"
-       einfo "Certain things on your system may have linked against a"
-       einfo "different version of com_err -- those things need to be"
-       einfo "recompiled.  Sorry for the inconvenience"
-       echo
-       epause 10
-       ebeep
-}
diff --git a/sys-libs/com_err/files/com_err-1.37-makefile.patch b/sys-libs/com_err/files/com_err-1.37-makefile.patch
deleted file mode 100644 (file)
index b60ea5a..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-Fix the symlinks that submakefiles create so that they don't suck at life.
-
-Don't use target LDFLAGS/CFLAGS when compiling native apps.
-
---- lib/Makefile.elf-lib
-+++ lib/Makefile.elf-lib
-@@ -49,3 +49,3 @@
-       @echo " SYMLINK $(libdir)/$(ELF_IMAGE).so"
--      @$(LN_S) -f $(ELF_INSTALL_DIR)/$(ELF_SONAME) \
-+      @$(LN_S) -f $(ELF_SONAME) \
-               $(DESTDIR)$(libdir)/$(ELF_IMAGE).so
---- util/Makefile.in
-+++ util/Makefile.in
-@@ -15,7 +15,7 @@
- .c.o:
-       @echo " CC $<"
--      @$(BUILD_CC) -c $(ALL_CFLAGS) $< -o $@
-+      @$(BUILD_CC) -c $(DEFS) $< -o $@
- PROGS=                subst
-@@ -23,11 +23,11 @@
- subst: subst.o
-       @echo " LD $@"
--      @$(BUILD_CC) $(ALL_LDFLAGS) -o subst subst.o
-+      @$(BUILD_CC) -o subst subst.o
- copy_sparse: copy_sparse.o
-       @echo " LD $@"
--      @$(BUILD_CC) $(ALL_LDFLAGS) -o copy_sparse copy_sparse.o
-+      @$(BUILD_CC) -o copy_sparse copy_sparse.o
- gen-tarball: $(srcdir)/gen-tarball.in $(top_builddir)/config.status
-       @echo " CONFIG.STATUS $@"
---- lib/Makefile.elf-lib
-+++ lib/Makefile.elf-lib
-@@ -26,7 +26,7 @@
- $(ELF_LIB): $(OBJS)
-       @echo " GEN_ELF_SOLIB $(ELF_LIB)"
--      @(cd elfshared; $(CC) --shared -o $(ELF_LIB) \
-+      @(cd elfshared; $(CC) --shared -o $(ELF_LIB) $(LDFLAGS) \
-               -Wl,-soname,$(ELF_SONAME) $(OBJS) $(ELF_OTHER_LIBS))
-       @$(MV) elfshared/$(ELF_LIB) .
-       @$(RM) -f ../$(ELF_LIB) ../$(ELF_IMAGE).so ../$(ELF_SONAME)
diff --git a/sys-libs/com_err/files/digest-com_err-1.38 b/sys-libs/com_err/files/digest-com_err-1.38
deleted file mode 100644 (file)
index b74c52b..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d774d4412bfb80d12cf3a4fdfd59de5a e2fsprogs-1.38.tar.gz 3621193
-RMD160 492071c29e9a0adc1bed0762e795efb6b29a692c e2fsprogs-1.38.tar.gz 3621193
-SHA256 c4e482687d0cff240d02a70fcf423cc14296b6a7869cd8dd42d5404d098e0bb7 e2fsprogs-1.38.tar.gz 3621193