dev-vcs/mercurial-server: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Sun, 19 Apr 2020 07:12:24 +0000 (09:12 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 19 Apr 2020 07:12:24 +0000 (09:12 +0200)
Closes: https://bugs.gentoo.org/712114
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-vcs/mercurial-server/Manifest [deleted file]
dev-vcs/mercurial-server/mercurial-server-1.2-r1.ebuild [deleted file]
dev-vcs/mercurial-server/mercurial-server-9999.ebuild [deleted file]
dev-vcs/mercurial-server/metadata.xml [deleted file]
profiles/package.mask

diff --git a/dev-vcs/mercurial-server/Manifest b/dev-vcs/mercurial-server/Manifest
deleted file mode 100644 (file)
index af6b8fd..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST mercurial-server_1.2.tar.gz 21560 BLAKE2B 60d7dd9d0fdb55fc82d8cd268ab7ec7a53b1ba425c28520bff2f4920c1e404fbe0c0bb11e4af34b1952a8cdb2f44cecba1b5f29c6c5d85f49e992bd31cd88c1d SHA512 3dec14309fc050fa49ffd5253a491b2d65507ed8da04741ba5247d420701a9f836a1c3ef6924a706671e28bafbe0200af03c817184e303179002419887400ce0
diff --git a/dev-vcs/mercurial-server/mercurial-server-1.2-r1.ebuild b/dev-vcs/mercurial-server/mercurial-server-1.2-r1.ebuild
deleted file mode 100644 (file)
index ab1be82..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# force single impl to avoid python-exec wrapping
-DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 user
-
-if [[ "${PV}" = "9999" ]]; then
-       inherit mercurial
-       EHG_REPO_URI="http://hg.opensource.lshift.net/mercurial-server"
-       KEYWORDS=""
-else
-       MY_P="${PN}_${PV}"
-       SRC_URI="http://dev.lshift.net/paul/mercurial-server/${MY_P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-       S="${WORKDIR}/${MY_P}.orig"
-fi
-
-DESCRIPTION="Mercurial authentication and authorization tools"
-HOMEPAGE="http://www.lshift.net/mercurial-server.html"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND="dev-vcs/mercurial"
-DEPEND="${RDEPEND}
-       doc? (
-               app-text/docbook-xsl-stylesheets
-               dev-libs/libxslt
-       )"
-
-pkg_setup() {
-       enewgroup hg
-       enewuser hg -1 /bin/bash "/var/lib/${PN}" hg
-       python-single-r1_pkg_setup
-}
-
-python_prepare_all() {
-       # remove useless makefile
-       rm Makefile || die
-
-       # fix installation paths
-       sed -i -e "s|'init'|'share/${PN}/init'|" setup.py \
-               || die 'sed setup.py failed.'
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # build documentation
-       if use doc; then
-               xsltproc --nonet -o manual.html \
-                       /usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl \
-                       doc/manual.docbook || die "xsltproc failed"
-       fi
-}
-
-python_install() {
-       distutils-r1_python_install --install-scripts="/usr/share/${PN}"
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       # install configuration files
-       insinto "/etc/${PN}"
-       doins -r src/init/conf/.
-       keepdir /etc/mercurial-server/keys/{root,users}
-
-       # install documentation
-       use doc && dodoc manual.html
-
-       # install hg home directory
-       keepdir "/var/lib/${PN}"
-       fowners hg:hg "/var/lib/${PN}"
-       fperms 750 "/var/lib/${PN}"
-}
diff --git a/dev-vcs/mercurial-server/mercurial-server-9999.ebuild b/dev-vcs/mercurial-server/mercurial-server-9999.ebuild
deleted file mode 100644 (file)
index 701b332..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# force single impl to avoid python-exec wrapping
-DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 user
-
-if [[ "${PV}" = "9999" ]]; then
-       inherit mercurial
-       EHG_REPO_URI="http://hg.opensource.lshift.net/mercurial-server"
-       KEYWORDS=""
-else
-       MY_P="${PN}_${PV}"
-       SRC_URI="http://dev.lshift.net/paul/mercurial-server/${MY_P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-       S="${WORKDIR}/${MY_P}"
-fi
-
-DESCRIPTION="Mercurial authentication and authorization tools"
-HOMEPAGE="http://www.lshift.net/mercurial-server.html"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND="dev-vcs/mercurial"
-DEPEND="${RDEPEND}
-       doc? (
-               app-text/docbook-xsl-stylesheets
-               dev-libs/libxslt
-       )"
-
-pkg_setup() {
-       enewgroup hg
-       enewuser hg -1 /bin/bash "/var/lib/${PN}" hg
-       python-single-r1_pkg_setup
-}
-
-python_prepare_all() {
-       # remove useless makefile
-       rm Makefile || die
-
-       # fix installation paths
-       sed -i -e "s|'init'|'share/${PN}/init'|" setup.py \
-               || die 'sed setup.py failed.'
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # build documentation
-       if use doc; then
-               xsltproc --nonet -o manual.html \
-                       /usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl \
-                       doc/manual.docbook || die "xsltproc failed"
-       fi
-}
-
-python_install() {
-       distutils-r1_python_install --install-scripts="/usr/share/${PN}"
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       # install configuration files
-       insinto "/etc/${PN}"
-       doins -r src/init/conf/.
-       keepdir /etc/mercurial-server/keys/{root,users}
-
-       # install documentation
-       use doc && dodoc manual.html
-
-       # install hg home directory
-       keepdir "/var/lib/${PN}"
-       fowners hg:hg "/var/lib/${PN}"
-       fperms 750 "/var/lib/${PN}"
-}
diff --git a/dev-vcs/mercurial-server/metadata.xml b/dev-vcs/mercurial-server/metadata.xml
deleted file mode 100644 (file)
index a59ea4d..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <!-- maintainer-needed -->
-       <longdescription lang="en">
-               mercurial-server gives your developers remote read/write access to
-               centralized Mercurial repositories using SSH public key authentication; it
-               provides convenient and fine-grained key management and access control.
-       </longdescription>
-</pkgmetadata>
index 8080bc1793f08b88fd8c32059f30748bffc096c9..f584f7d4a422d1d4003b5737520c39cb0960cb20 100644 (file)
@@ -590,7 +590,6 @@ www-apps/trac-tags
 dev-vcs/hgsubversion
 dev-vcs/hgsvn
 dev-vcs/hgview
-dev-vcs/mercurial-server
 dev-vcs/tortoisehg
 
 # Eray Aslan <eras@gentoo.org> (2020-03-09)