net-libs/rb_libtorrent: link the python bindings against the right libpython version
authorPatrick McLean <chutzpah@gentoo.org>
Thu, 16 Mar 2017 23:26:31 +0000 (16:26 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 16 Mar 2017 23:26:31 +0000 (16:26 -0700)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild

index c3a54a8c6d7cdba1c1075759a67c5d2ed7e3dba5..5a8412d4f63d49cb77dcedf05d089deb838c0b1d 100644 (file)
@@ -71,12 +71,10 @@ src_configure() {
        econf "${myeconfargs[@]}"
 
        if use python; then
-               myeconfargs+=(
-                       --enable-python-binding
-                       --with-boost-python
-               )
                python_configure() {
-                       econf "${myeconfargs[@]}"
+                       econf "${myeconfargs[@]}" \
+                               --enable-python-binding \
+                               --with-boost-python="${EPYTHON#python}"
                }
                distutils-r1_src_configure
        fi