dev-util/glslang: 9999 cleanup, cmake.eclass
authorMatt Turner <mattst88@gentoo.org>
Sun, 15 Mar 2020 20:42:57 +0000 (13:42 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sun, 15 Mar 2020 21:28:02 +0000 (14:28 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-util/glslang/glslang-9999.ebuild

index bbdb6606eab1b756bef4b2baaeb79fb977ca482a..6de396f95da77f793d35708bd6fed249ddb9508b 100644 (file)
@@ -1,23 +1,26 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-PYTHON_COMPAT=(python{3_6,3_7})
+CMAKE_ECLASS="cmake"
+PYTHON_COMPAT=( python3_{6,7} )
+inherit cmake-multilib python-any-r1
 
-inherit cmake-multilib cmake-utils python-any-r1 git-r3
-
-EGIT_REPO_URI="https://github.com/KhronosGroup/glslang.git"
-SRC_URI=""
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
 
 DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
-HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
 
 LICENSE="BSD"
 SLOT="0"
 
-PATCHES=( "${FILESDIR}/${P}-fix-relative-includes.patch" )
-
 RDEPEND="!<media-libs/shaderc-2019-r1"
 BDEPEND="${PYTHON_DEPS}"