sys-fs/treesize: Fix building with CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Fri, 15 May 2020 07:01:38 +0000 (09:01 +0200)
committerJeroen Roovers <jer@gentoo.org>
Fri, 15 May 2020 07:02:19 +0000 (09:02 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Closes: https://bugs.gentoo.org/706844
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
sys-fs/treesize/files/0.54.1-amd64.patch
sys-fs/treesize/files/0.54.1-fno-common.patch [new file with mode: 0644]
sys-fs/treesize/treesize-0.54.1-r1.ebuild

index c03df8a258e7a1515c90c5de9999fbcf738ead07..dd45436e75e5e18b14e11347d7473a1471706bb0 100644 (file)
@@ -1,5 +1,5 @@
---- a/src/ui-util.c    2007-11-16 22:08:01.000000000 +0100
-+++ b/src/ui-util.c    2009-05-09 11:34:59.000000000 +0200
+--- a/src/ui-util.c
++++ b/src/ui-util.c
 @@ -18,6 +18,7 @@
  
  #include "ui-util.h"
diff --git a/sys-fs/treesize/files/0.54.1-fno-common.patch b/sys-fs/treesize/files/0.54.1-fno-common.patch
new file mode 100644 (file)
index 0000000..7001b4b
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -39,7 +39,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-GdkPixbuf* gdkTreeSize;
++extern GdkPixbuf* gdkTreeSize;
+ GtkMenu *TreeSizeMenuGlobal;
+ GtkWidget *mainWindow;
index 315e9e86c23f8123fd6495dab23d533eccea651e..90940c262473c2fb10d2a91e10d7fdcf6ef5d939 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -16,7 +16,10 @@ KEYWORDS="amd64 x86"
 RDEPEND="x11-libs/gtk+:2"
 DEPEND="${RDEPEND}"
 
-PATCHES=( "${FILESDIR}/${PV}-amd64.patch" )
+PATCHES=(
+       "${FILESDIR}"/${PV}-amd64.patch
+       "${FILESDIR}"/${PV}-fno-common.patch
+)
 
 src_prepare() {
        default