sys-apps/cpuid: drop old version
authorConrad Kostecki <conikost@gentoo.org>
Sun, 15 Dec 2019 17:18:02 +0000 (18:18 +0100)
committerConrad Kostecki <conikost@gentoo.org>
Sun, 15 Dec 2019 17:18:02 +0000 (18:18 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
sys-apps/cpuid/Manifest
sys-apps/cpuid/cpuid-20180419.ebuild [deleted file]
sys-apps/cpuid/files/cpuid-20170122-Makefile.patch [deleted file]
sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch [deleted file]

index 326f544e1c62d74918d19ed876b221cd8aaff8db..7e34bf03aaf7be6af4a2dce3ff9f9233dc2167bc 100644 (file)
@@ -1,2 +1 @@
-DIST cpuid-20180419.src.tar.gz 82301 BLAKE2B 6905c0946fb9a930c67718067923c8c238031539c95704664160efde8563b0f56aadf3132abc9833310846802f97330edff833b47c006a4f46fec49358b56e31 SHA512 c8e30e45df7be5bdbff7e449b447b4542326a112f563c114c67cc80764070f3f3815ff4f80ceb57360828061bc9fd5f2f24f8e53ae4db47781f36db32141c951
 DIST cpuid-20180519.src.tar.gz 84784 BLAKE2B 87098145a378081d296f0473f9106e7c5b6654c2bd63d385dc27e293079adf3a527801fa644000ede53228e087e9e9afdf807a3c8d9cc8eb93826f01a5a89e9a SHA512 565738c41777669e750a2ef2e122ed0568de5ac8cc2584fa5047ba66d42eb5c3324b283bda25605e055d85402a4e2d109bc6d033ccd34243caab728465792669
diff --git a/sys-apps/cpuid/cpuid-20180419.ebuild b/sys-apps/cpuid/cpuid-20180419.ebuild
deleted file mode 100644 (file)
index 0d0367d..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Utility to get detailed information about the CPU(s) using the CPUID instruction"
-HOMEPAGE="http://www.etallen.com/cpuid.html"
-SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="
-       app-arch/gzip
-       dev-lang/perl"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-20170122-Makefile.patch
-       "${FILESDIR}"/${PN}-20170122-missing-include-sysmacros.patch
-)
-
-src_configure() {
-       tc-export CC
-}
-
-src_install() {
-       emake BUILDROOT="${ED}" install
-       einstalldocs
-}
diff --git a/sys-apps/cpuid/files/cpuid-20170122-Makefile.patch b/sys-apps/cpuid/files/cpuid-20170122-Makefile.patch
deleted file mode 100644 (file)
index 9a02a54..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -ru cpuid-20170122.orig/Makefile cpuid-20170122/Makefile
---- cpuid-20170122.orig/Makefile       2017-06-16 06:54:32.993875817 -0700
-+++ cpuid-20170122/Makefile    2017-06-16 06:55:56.622875498 -0700
-@@ -1,9 +1,3 @@
--CFLAGS+=-g
--CPPFLAGS?=
--LDFLAGS?=
--ifneq (,$(findstring arch=i386,$(CFLAGS)))
--CISA=-m32
--endif
- CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
- PACKAGE=cpuid
-@@ -51,10 +45,10 @@
-       gzip < $< > $@
- install: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
--      install -D -s -m 755 $(PROG)              $(BUILDROOT)/usr/bin/$(PROG)
--      install -D    -m 444 $(PROG).man.gz       $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
--      install -D    -m 755 cpuinfo2cpuid        $(BUILDROOT)/usr/bin/cpuinfo2cpuid
--      install -D    -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
-+      install -D -m 755 $(PROG)              $(BUILDROOT)/usr/bin/$(PROG)
-+      install -D -m 444 $(PROG).man.gz       $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
-+      install -D -m 755 cpuinfo2cpuid        $(BUILDROOT)/usr/bin/cpuinfo2cpuid
-+      install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
- clean:
-       rm -f $(PROG) $(PROG).i386 $(PROG).x86_64
diff --git a/sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch b/sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch
deleted file mode 100644 (file)
index bba18a3..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-Bug: https://bugs.gentoo.org/show_bug.cgi?id=604406
-
---- a/cpuid.c
-+++ b/cpuid.c
-@@ -30,6 +30,7 @@
- #define _GNU_SOURCE
- #include <stdio.h>
- #include <sys/types.h>
-+#include <sys/sysmacros.h>
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <errno.h>