dev-python/ramlfications: New package, dep og buildbot-0.9
authorBrian Dolbec <dolsen@gentoo.org>
Tue, 9 Aug 2016 22:17:12 +0000 (15:17 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Tue, 9 Aug 2016 23:47:21 +0000 (16:47 -0700)
Package-Manager: portage-2.3.0

dev-python/ramlfications/Manifest [new file with mode: 0644]
dev-python/ramlfications/metadata.xml [new file with mode: 0644]
dev-python/ramlfications/ramlfications-0.1.9.ebuild [new file with mode: 0644]

diff --git a/dev-python/ramlfications/Manifest b/dev-python/ramlfications/Manifest
new file mode 100644 (file)
index 0000000..a69a837
--- /dev/null
@@ -0,0 +1 @@
+DIST ramlfications-0.1.9.tar.gz 1094577 SHA256 7bb89c11b13bc6b4099ee7fa07c5285a54b64a5e9c71eb6ca99660358fb27677 SHA512 5f93556e8f008b86bbe1e3b96dba3b20a31e583800334931b9c3972da897bc19a93ba5fdd687799e99aee79a93e10e58ca1b3eb5b0f38fb2b28d0f0ba0723e82 WHIRLPOOL b58c21ab3d03578fe69bd29f331744c81ff5d88ce0ed7f03c1d0abd72058069638413043d8b63cb6e8a5a2b11b078b60cb5c1baf2491e73c44a33700cd51c97a
diff --git a/dev-python/ramlfications/metadata.xml b/dev-python/ramlfications/metadata.xml
new file mode 100644 (file)
index 0000000..ea8b031
--- /dev/null
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>dolsen@gentoo.org</email>
+               <name>Brian Dolbec</name>
+               <description>Primary maintainer</description>
+       </maintainer>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+               <name>Python</name>
+       </maintainer>
+       <upstream>
+               <maintainer>
+                       <email>spam@lynnroot.com</email>
+                       <name>Lynn Root</name>
+               </maintainer>
+               <remote-id type="pypi">ramlfications</remote-id>
+       </upstream>
+       <longdescription>ramlfications is an Apache-2.0 licensed reference implementation
+of a RAML parser in Python intended to be used for parsing API definitions
+(e.g. for static documentation-generation).
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/ramlfications/ramlfications-0.1.9.ebuild b/dev-python/ramlfications/ramlfications-0.1.9.ebuild
new file mode 100644 (file)
index 0000000..44d8fe5
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 pypy)
+
+inherit eutils distutils-r1
+
+DESCRIPTION="RAML reference implementation in Python"
+HOMEPAGE="https://ramlfications.readthedocs.org/ https://pypi.python.org/pypi/ramlfications/"
+SRC_URI="https://github.com/spotify/${PN}/releases/download/0.1.9/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}]
+       dev-python/markdown2[${PYTHON_USEDEP}]
+       dev-python/jsonref[${PYTHON_USEDEP}]
+       dev-python/click[${PYTHON_USEDEP}]
+       dev-python/attrs[${PYTHON_USEDEP}]
+       dev-python/termcolor[${PYTHON_USEDEP}]
+       dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+DEPEND="
+       ${RDEPEND}
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )
+"