net-wireless/tempestsdr: switch to my fork
authorRick Farina <zerochaos@gentoo.org>
Tue, 12 Nov 2019 18:09:08 +0000 (13:09 -0500)
committerRick Farina <zerochaos@gentoo.org>
Tue, 12 Nov 2019 18:09:23 +0000 (13:09 -0500)
mostly fixed, with bonus support from deltj

Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
net-wireless/tempestsdr/tempestsdr-9999.ebuild

index 167bdba6e6f6166f3711f5fc420f9b338d017819..d94f6edd78293cfbe853aeb95341774db1373363 100644 (file)
@@ -6,30 +6,30 @@ EAPI=7
 inherit git-r3 java-pkg-2
 
 DESCRIPTION="Remote video eavesdropping using a software-defined radio platform"
-HOMEPAGE="https://github.com/tanpc/TempestSDR"
-EGIT_REPO_URI="https://github.com/tanpc/TempestSDR.git"
+HOMEPAGE="https://github.com/deltj/TempestSDR.git"
+EGIT_REPO_URI="https://github.com/deltj/TempestSDR.git"
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS=""
 IUSE=""
 
-RDEPEND=">=virtual/jre-1.7"
-DEPEND=">=virtual/jdk-1.7"
+DEPEND=">=virtual/jdk-1.7:*
+               net-wireless/airspy
+               net-wireless/uhd:=
+               net-wireless/rtl-sdr
+               net-wireless/bladerf:=
+               net-wireless/hackrf-tools"
+RDEPEND="${DEPEND}"
 BDEPEND=""
 
 src_prepare() {
-       sed -i -e 's#javah#javac -h .#' \
-               -e 's#-jni martin.tempest.core.TSDRLibrary##' \
-               -e 's#-o TSDRLibraryNDK.h#../src/martin/tempest/core/TSDRLibrary.java#' JavaGUI/jni/makefile || die
-       sed -i -e 's#TSDRLibraryNDK.h#martin_tempest_core_TSDRLibrary.h#g' JavaGUI/jni/TSDRLibraryNDK.c
        #airspy mini support, but may degrade airspy support, needs testing
        #sed -i -e 's#10e6#6e6#g' -e 's#10000000#6000000#g' TSDRPlugin_Airspy/src/TSDRPlugin_Airspy.cpp
        default
 }
 
 src_compile() {
-       emake clean
        #this absolutely breaks in wierd ways when built parallel
        emake -j1 all
 }