games-fps/unreal-tournament-bonuspacks: EAPI=5
authorMichael Sterrett <mr_bones_@gentoo.org>
Tue, 12 Jan 2016 07:14:34 +0000 (02:14 -0500)
committerMichael Sterrett <mr_bones_@gentoo.org>
Tue, 12 Jan 2016 07:47:37 +0000 (02:47 -0500)
Package-Manager: portage-2.2.26

games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild

index d9989a8af10d0e0db3cc729395521f5bc13512ee..b470f0ddf2e696429bdaf8633bcc314b20017876 100644 (file)
@@ -2,6 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
+EAPI=5
 inherit games
 
 DESCRIPTION="Futuristic FPS (bonus packs)"
@@ -11,8 +12,7 @@ HOMEPAGE="http://www.unrealtournament.com/"
 # [UTBonusPack2] -> loki put into games-fps/unreal-tournament
 # [UTiNoxxPack]  -> loki put into games-fps/unreal-tournament
 # [UTBonusPack4] -> none of this is in games-fps/unreal-tournament
-SRC_URI="http://fileserver.talkware.net/ut/bonuspacks/UTBonusPack4.zip
-       http://www.dices.de/dices/files/UTBonusPack4.zip"
+SRC_URI="http://fpsnetwork.com/downloads/ut99/bonuspacks/UTBonusPack4.zip"
 
 LICENSE="all-rights-reserved"
 SLOT="0"
@@ -20,20 +20,18 @@ KEYWORDS="-* amd64 x86"
 IUSE=""
 RESTRICT="mirror bindist"
 
-DEPEND="app-arch/unzip
-       || (
-               games-fps/unreal-tournament
-               games-fps/unreal-tournament-goty )
-       games-util/umodpack"
 RDEPEND="|| (
        games-fps/unreal-tournament
        games-fps/unreal-tournament-goty )"
+DEPEND="${RDEPEND}
+       app-arch/unzip
+       games-util/umodpack"
 
 S=${WORKDIR}
 
 src_install() {
        # unpack the UTBonusPack4 umod
-       umod -v -b "$(pwd)" -x UTBonusPack4.umod || die "could not unpack UTBonusPack4.umod"
+       umod -v -b "$(pwd)" -x UTBonusPack4.umod || die
 
        # move stuff around
        rm UTBonusPack4.umod