dev-util/sysdig: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:29:22 +0000 (11:29 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:36:56 +0000 (11:36 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/sysdig/Manifest
dev-util/sysdig/sysdig-0.26.4-r1.ebuild [deleted file]
dev-util/sysdig/sysdig-0.26.4.ebuild [deleted file]

index a55a5d704af5680a231de9cd274470983eab6278..e1493303a0bd736cea8cc94338b6532e6c7ee6e3 100644 (file)
@@ -1,2 +1 @@
-DIST sysdig-0.26.4.tar.gz 902181 BLAKE2B a7ac38be2f7a3d7e4f4fdec6a2fbf5305a8224ee27352da70f509139ebefd14616f84c7b8860f50d2546819a94deb1117034bceddd22128fcf25386b835274f2 SHA512 f56f5d0a522b861df4803bfdafcaf8db3fc9c0e751d06c321082757f6828a210cb86bab4550a3b35bf6412f930e44ab0f5cf709a30651c57dd7064a68e273a88
 DIST sysdig-0.26.6.tar.gz 923918 BLAKE2B e022eba30977f5300c80a4806926d3e755b1395f05475c1fe925b86823670e397ad29e8bd18b1beaa893cb1bf83c329960c1bf9ff6faf0a5144343e88d52a4a0 SHA512 94784f0dfe46924b81d8804d950a9563cd18f4aa8b1cacd7e27e3974ecf7215223e03bdab001f408f64eb6c72f0da5082fd922d63079119427eb493c77e15795
diff --git a/dev-util/sysdig/sysdig-0.26.4-r1.ebuild b/dev-util/sysdig/sysdig-0.26.4-r1.ebuild
deleted file mode 100644 (file)
index 7ad2a99..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 cmake
-
-DESCRIPTION="A system exploration and troubleshooting tool"
-HOMEPAGE="https://sysdig.com/"
-SRC_URI="https://github.com/draios/sysdig/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="libressl +modules"
-
-RDEPEND="
-       app-misc/jq:0=
-       dev-cpp/tbb:0=
-       dev-lang/luajit:2=
-       >=dev-libs/jsoncpp-0.6_pre:0=
-       dev-libs/libb64:0=
-       dev-libs/protobuf:0=
-       net-dns/c-ares:0=
-       net-libs/grpc:0=
-       sys-libs/ncurses:0=
-       sys-libs/zlib:0=
-       libressl? ( dev-libs/libressl:0= )
-       !libressl? ( dev-libs/openssl:0= )
-       net-misc/curl:0="
-DEPEND="${RDEPEND}
-       virtual/os-headers"
-PDEPEND="
-       modules? ( >=dev-util/sysdig-kmod-${PV} )"
-
-src_prepare() {
-       sed -i -e 's:-ggdb::' CMakeLists.txt || die
-
-       cmake_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               # done in dev-util/sysdig-kmod
-               -DBUILD_DRIVER=OFF
-               # libscap examples are not installed or really useful
-               -DBUILD_LIBSCAP_EXAMPLES=OFF
-
-               # unbundle the deps
-               -DUSE_BUNDLED_DEPS=OFF
-       )
-
-       cmake_src_configure
-}
-
-src_install() {
-       cmake_src_install
-
-       # remove sources
-       rm -r "${ED}"/usr/src || die
-
-       # move bashcomp to the proper location
-       dobashcomp "${ED}"/usr/etc/bash_completion.d/sysdig || die
-       rm -r "${ED}"/usr/etc || die
-}
diff --git a/dev-util/sysdig/sysdig-0.26.4.ebuild b/dev-util/sysdig/sysdig-0.26.4.ebuild
deleted file mode 100644 (file)
index 682c846..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MODULES_OPTIONAL_USE=modules
-inherit linux-mod bash-completion-r1 cmake-utils
-
-DESCRIPTION="A system exploration and troubleshooting tool"
-HOMEPAGE="https://sysdig.com/"
-SRC_URI="https://github.com/draios/sysdig/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0
-       modules? ( || ( MIT GPL-2 ) )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="libressl +modules"
-
-RDEPEND="
-       app-misc/jq:0=
-       dev-cpp/tbb:0=
-       dev-lang/luajit:2=
-       >=dev-libs/jsoncpp-0.6_pre:0=
-       dev-libs/libb64:0=
-       dev-libs/protobuf:0=
-       net-dns/c-ares:0=
-       net-libs/grpc:0=
-       sys-libs/ncurses:0=
-       sys-libs/zlib:0=
-       libressl? ( dev-libs/libressl:0= )
-       !libressl? ( dev-libs/openssl:0= )
-       net-misc/curl:0="
-DEPEND="${RDEPEND}
-       app-arch/xz-utils
-       virtual/os-headers"
-
-# needed for the kernel module
-CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
-
-pkg_pretend() {
-       linux-mod_pkg_setup
-}
-
-pkg_setup() {
-       linux-mod_pkg_setup
-}
-
-src_prepare() {
-       sed -i -e 's:-ggdb::' CMakeLists.txt || die
-
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               # we will use linux-mod for that
-               -DBUILD_DRIVER=OFF
-               # libscap examples are not installed or really useful
-               -DBUILD_LIBSCAP_EXAMPLES=OFF
-
-               # unbundle the deps
-               -DUSE_BUNDLED_DEPS=OFF
-       )
-
-       cmake-utils_src_configure
-
-       # setup linux-mod ugliness
-       MODULE_NAMES="sysdig-probe(extra:${BUILD_DIR}/driver/src:)"
-       BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
-       BUILD_TARGETS="all"
-}
-
-src_compile() {
-       cmake-utils_src_compile
-       linux-mod_src_compile
-}
-
-src_install() {
-       cmake-utils_src_install
-       linux-mod_src_install
-
-       # remove sources
-       rm -r "${ED}"/usr/src || die
-
-       # move bashcomp to the proper location
-       dobashcomp "${ED}"/usr/etc/bash_completion.d/sysdig || die
-       rm -r "${ED}"/usr/etc || die
-}