x11-misc/urxvt-perls: introduce 'deprecated' USE
authorJoonas Niilola <juippis@gentoo.org>
Wed, 25 Mar 2020 19:34:11 +0000 (21:34 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 25 Mar 2020 19:34:52 +0000 (21:34 +0200)
 - to install deprecated scripts declared by upstream, put them
   behind USE flag because they might break some user configuration,
 - suggested by neeshy.

Closes: https://github.com/gentoo/gentoo/pull/15076
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-misc/urxvt-perls/metadata.xml
x11-misc/urxvt-perls/urxvt-perls-2.3-r1.ebuild [new file with mode: 0644]

index 67c8b7560e0f04a1299a365fb39a4d7e92ebe8e8..d787dd460150b7cfe8b95430a9ec6f9b58c864d1 100644 (file)
@@ -5,6 +5,9 @@
     <email>juippis@gentoo.org</email>
     <name>Joonas Niilola</name>
   </maintainer>
+  <use>
+    <flag name="deprecated">Install scripts which have been marked as deprecated by upstream</flag>
+  </use>
   <upstream>
     <remote-id type="github">muennich/urxvt-perls</remote-id>
   </upstream>
diff --git a/x11-misc/urxvt-perls/urxvt-perls-2.3-r1.ebuild b/x11-misc/urxvt-perls/urxvt-perls-2.3-r1.ebuild
new file mode 100644 (file)
index 0000000..76baa0b
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Perl extensions for rxvt-unicode"
+HOMEPAGE="https://github.com/muennich/urxvt-perls"
+SRC_URI="https://github.com/muennich/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="deprecated"
+
+RDEPEND="x11-misc/xsel
+       x11-terms/rxvt-unicode[perl]"
+
+src_install() {
+       insinto /usr/$(get_libdir)/urxvt/perl
+       doins keyboard-select
+
+       use deprecated && doins deprecated/{clipboard,url-select}
+
+       einstalldocs
+}