dev-libs/libdbh: 5.0.22 version bump
authorFrederic Culot <culot@FreeBSD.org>
Thu, 31 May 2018 18:42:04 +0000 (20:42 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 13 Jun 2018 10:25:50 +0000 (12:25 +0200)
Closes: https://bugs.gentoo.org/656990

dev-libs/libdbh/Manifest
dev-libs/libdbh/libdbh-5.0.22.ebuild [new file with mode: 0644]

index d8950e312f7ee8dda949875378a3dca99b2beb7c..d04ff167358a012afcf6457f560a2cdfae7472df 100644 (file)
@@ -1 +1,2 @@
 DIST libdbh2-5.0.19.tar.gz 1608949 BLAKE2B 405a2903c8f4dddcd66153304bfff5084e549f650846cc2e8afecb6783cbb5fcf391cc251e4805486f9ad62cac4c59a3112fc7a6d0ced6e93e0e88be707e9a83 SHA512 35c368e82f8f7c4c7d4960731214ff3863530795b16716c0be7351e0ca10740ac26a99930369f4df78c8e108d929124c222b5942ce5f521ecb58afd38d55bbe9
+DIST libdbh2-5.0.22.tar.gz 1641669 BLAKE2B 835a1d112ac34ff025002c826fa6f1291a8da2442901396e79abbf5e3c315654cef2a9d45c852821fa373b132e0e8a04695c4cf5c830bac9a3b40dd32ce5b543 SHA512 d0cb69bbd3d54600cd14f4d1d7ee7f87c52c9bea9f475763b1d43c053a7571063f42b59cef8d08632b065f44cd85b5ccb0fcd31052202aa8f8a49f34669c7930
diff --git a/dev-libs/libdbh/libdbh-5.0.22.ebuild b/dev-libs/libdbh/libdbh-5.0.22.ebuild
new file mode 100644 (file)
index 0000000..a32cdfb
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+MY_P=${PN}2-${PV}
+
+DESCRIPTION="A small library to create and manage 64-bit disk based hash tables"
+HOMEPAGE="https://www.gnu.org/software/libdbh/"
+SRC_URI="mirror://sourceforge/dbh/dbh/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/gtk-doc-am
+       virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       default
+
+       # Make sure user defined CFLAGS are respected
+       sed -i -e 's:-O2:${CFLAGS}:' m4/rfm-conditionals.m4 || die "sed failed"
+       eautoreconf
+}
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}