dev-go/sanitized-anchor-name: new package
authorWilliam Hubbs <williamh@gentoo.org>
Mon, 24 Aug 2015 22:43:23 +0000 (17:43 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 24 Aug 2015 23:01:28 +0000 (18:01 -0500)
This is a library which provides sanitized anchor names. It is a third
party library used by the blackfriday markdown processor.

dev-go/sanitized-anchor-name/Manifest [new file with mode: 0644]
dev-go/sanitized-anchor-name/metadata.xml [new file with mode: 0644]
dev-go/sanitized-anchor-name/sanitized-anchor-name-0_pre20150822.ebuild [new file with mode: 0644]
dev-go/sanitized-anchor-name/sanitized-anchor-name-9999.ebuild [new file with mode: 0644]

diff --git a/dev-go/sanitized-anchor-name/Manifest b/dev-go/sanitized-anchor-name/Manifest
new file mode 100644 (file)
index 0000000..0a45760
--- /dev/null
@@ -0,0 +1 @@
+DIST sanitized-anchor-name-0_pre20150822.tar.gz 1298 SHA256 71051787c19aff363bcccf1ea6f62baab7c46dfdc519e88043fe54b0de55ee21 SHA512 9fcaecd3962b2d4681faea7ef022b1cd6a9a6fe6c02a9608a7c57fcdb77eff6148be05debf6beb548530a9e56225596290525eb01b082601a3ee18130c9349f0 WHIRLPOOL 42e650e9132cf95f8f0fe34b0c38f16802747b48f62c7d00e903436fa4025da4848f864ca29ea66db4a9b7c9833d96dbd4a80de40a2b887b1553d1f52689c0ca
diff --git a/dev-go/sanitized-anchor-name/metadata.xml b/dev-go/sanitized-anchor-name/metadata.xml
new file mode 100644 (file)
index 0000000..aa88c15
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>williamh@gentoo.org</email>
+               <name>William Hubbs</name>
+       </maintainer>
+       <longdescription lang="en">
+               This library provides sanitized anchor names.
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-go/sanitized-anchor-name/sanitized-anchor-name-0_pre20150822.ebuild b/dev-go/sanitized-anchor-name/sanitized-anchor-name-0_pre20150822.ebuild
new file mode 100644 (file)
index 0000000..3eec0dc
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN=github.com/shurcooL/sanitized_anchor_name
+
+if [[ ${PV} = *9999* ]]; then
+       inherit golang-vcs
+else
+       KEYWORDS="~amd64"
+       EGIT_COMMIT="244f5ac"
+       SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A Go function to provide sanitized anchor names"
+HOMEPAGE="https://github.com/shurcooL/sanitized_anchor_name"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
diff --git a/dev-go/sanitized-anchor-name/sanitized-anchor-name-9999.ebuild b/dev-go/sanitized-anchor-name/sanitized-anchor-name-9999.ebuild
new file mode 100644 (file)
index 0000000..3eec0dc
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN=github.com/shurcooL/sanitized_anchor_name
+
+if [[ ${PV} = *9999* ]]; then
+       inherit golang-vcs
+else
+       KEYWORDS="~amd64"
+       EGIT_COMMIT="244f5ac"
+       SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A Go function to provide sanitized anchor names"
+HOMEPAGE="https://github.com/shurcooL/sanitized_anchor_name"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""