app-crypt/minisign: add live ebuild
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 10 May 2019 23:43:02 +0000 (16:43 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 10 May 2019 23:43:50 +0000 (16:43 -0700)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
app-crypt/minisign/minisign-9999.ebuild [new file with mode: 0644]

diff --git a/app-crypt/minisign/minisign-9999.ebuild b/app-crypt/minisign/minisign-9999.ebuild
new file mode 100644 (file)
index 0000000..da90d6d
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Dead simple tool to sign files and verify signatures"
+HOMEPAGE="https://github.com/jedisct1/minisign"
+
+if [[ ${PV} == "9999" ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
+else
+       SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+IUSE=""
+
+DEPEND=">=dev-libs/libsodium-1.0.16:=[-minimal]"
+RDEPEND="${DEPEND}"