dev-python/pyopencl: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:52:17 +0000 (09:52 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:52:17 +0000 (09:52 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pyopencl/Manifest
dev-python/pyopencl/pyopencl-2016.1.ebuild [deleted file]

index eae0945a137d8c1d1ca3964912ef9010e4f4a7a3..d76f6492151f4d1721c8661a16f6407b71b128eb 100644 (file)
@@ -1,2 +1 @@
-DIST pyopencl-2016.1.tar.gz 311327 BLAKE2B 6efb1e6cf6721e5ef606b572963938849b92c7348255be798a4af0604a798dc7804d839a46459275cf0720953deaa8ea6dc46aef594ac11fa61fa231681e2fa3 SHA512 3be8da315f9b4a4e03071152bb5968c5c7b102cbae6c70f358438cfd7951d12970a76dd8e922187ff73e47f7d0ce7a070e6f303dbe364c016796fa65d7e1de71
 DIST pyopencl-2017.2.tar.gz 350145 BLAKE2B 12c481893158f97dec612256b36e710ab52356c8b5f644f3710b5e34d4d10df3b27137ad76f29543fe16b3da725471e206aa5f69c646a79a65246d6091c686a9 SHA512 49f2ff619d8c214a3962b8444e68ba415dda032abaf9eeab259fcd1b21fbaab10bd057035161baef7f0182995834082218a6667464c01645231a94c88aa5c18b
diff --git a/dev-python/pyopencl/pyopencl-2016.1.ebuild b/dev-python/pyopencl/pyopencl-2016.1.ebuild
deleted file mode 100644 (file)
index a755b73..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl
-       https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples opengl"
-
-RDEPEND="
-       >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
-       >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
-       >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
-       >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
-       dev-python/mako[${PYTHON_USEDEP}]
-       dev-python/numpy[${PYTHON_USEDEP}]
-       >=dev-python/pytools-2015.1.2[${PYTHON_USEDEP}]
-       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-       >=virtual/opencl-0-r1"
-DEPEND="${RDEPEND}"
-
-src_configure() {
-       local myconf=()
-       if use opengl; then
-               myconf+=(--cl-enable-gl)
-       fi
-
-       "${PYTHON}" configure.py \
-               --boost-compiler=gcc \
-               --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
-               --no-use-shipped-boost \
-               "${myconf[@]}"
-}
-
-python_install_all() {
-       if use examples; then
-               local EXAMPLES=( examples/. )
-               einfo "Some of the examples provided by this package require dev-python/matplotlib."
-       fi
-       distutils-r1_python_install_all
-}