fix up global vars, dbus-1.0 love, dependency updates
authorSaleem Abdulrasool <compnerd@gentoo.org>
Sun, 10 Dec 2006 06:59:43 +0000 (06:59 +0000)
committerSaleem Abdulrasool <compnerd@gentoo.org>
Sun, 10 Dec 2006 06:59:43 +0000 (06:59 +0000)
Package-Manager: portage-2.1.2_rc3

media-sound/muine/ChangeLog
media-sound/muine/muine-0.8.6.ebuild

index 82dd12eda2a429a16b611d2973cc91c11c741360..db3df9170765ca86461b44bf929ad22e36a65725 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for media-sound/muine
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/ChangeLog,v 1.37 2006/12/10 05:54:41 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/ChangeLog,v 1.38 2006/12/10 06:59:43 compnerd Exp $
+
+  10 Dec 2006; Saleem Abdulrasool <compnerd@gentoo.org> muine-0.8.6.ebuild:
+  Fix up global vars, dbus-1.0 love, dependency updates
 
   10 Dec 2006; Saleem Abdulrasool <compnerd@gentoo.org>
   -files/muine-0.8.2-autoconf.diff, -files/muine-0.8.3-64-bit-int.diff,
index 01e5b917667bb38b26620758a15d19d969e09f99..773700788ed4479bb074c612df3851a221ea771b 100644 (file)
@@ -1,68 +1,56 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/muine-0.8.6.ebuild,v 1.1 2006/11/14 03:31:37 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/muine-0.8.6.ebuild,v 1.2 2006/12/10 06:59:43 compnerd Exp $
 
 inherit gnome2 mono eutils multilib autotools
 
 DESCRIPTION="A music player for GNOME"
 HOMEPAGE="http://muine-player.org/"
-SRC_URI="${HOMEPAGE}/releases/${P}.tar.gz"
+SRC_URI="http://muine-player.org/releases/${P}.tar.gz"
 
 LICENSE="GPL-2"
-IUSE="xine mad vorbis flac aac"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="aac flac mad vorbis xine "
 
+# The GTK+ depend is not superflous, it is to get the correct version
 RDEPEND=">=dev-lang/mono-1.1
+       >=x11-libs/gtk+-2.6.0
        >=dev-dotnet/gtk-sharp-2.4.0
-       >=dev-dotnet/gnome-sharp-2.4.0
-       >=dev-dotnet/gnomevfs-sharp-2.4.0
        >=dev-dotnet/glade-sharp-2.4.0
+       >=dev-dotnet/gnome-sharp-2.4.0
        >=dev-dotnet/gconf-sharp-2.4.0
+       >=dev-dotnet/gnomevfs-sharp-2.4.0
+       sys-libs/gdbm
+       ~media-libs/flac-1.1.2
+       >=media-libs/libvorbis-1.0
+       >=media-libs/libid3tag-0.15.0b
+       || ( =sys-apps/dbus-0.61* =sys-apps/dbus-0.62* )
        xine? ( >=media-libs/xine-lib-1_rc4 )
        !xine? (
                =media-libs/gstreamer-0.10*
                =media-libs/gst-plugins-base-0.10*
                =media-libs/gst-plugins-good-0.10*
-               =media-plugins/gst-plugins-gnomevfs-0.10*
                =media-plugins/gst-plugins-gconf-0.10*
+               =media-plugins/gst-plugins-gnomevfs-0.10*
+               aac? ( =media-plugins/gst-plugins-faad-0.10*
+                       >=media-libs/faad2-2.0-r4 )
+               flac? ( =media-plugins/gst-plugins-flac-0.10* )
                mad? ( =media-plugins/gst-plugins-mad-0.10* )
                vorbis? ( =media-plugins/gst-plugins-ogg-0.10*
                        =media-plugins/gst-plugins-vorbis-0.10* )
-               flac? ( =media-plugins/gst-plugins-flac-0.10* )
-               aac? (
-                       =media-plugins/gst-plugins-faad-0.10*
-                       >=media-libs/faad2-2.0-r4
-               )
-       )
-       >=media-libs/libid3tag-0.15.0b
-       >=media-libs/libvorbis-1.0
-       sys-libs/gdbm
-       >=gnome-base/gconf-2.0.0
-       >=gnome-base/gnome-vfs-2.0.0
-       >=x11-libs/gtk+-2.6.0
-       >=dev-util/intltool-0.29
-       >=sys-apps/dbus-0.23.2-r1
-       ~media-libs/flac-1.1.2"
-
+       )"
 DEPEND="${RDEPEND}
-       gnome-base/gnome-common
-       >=dev-util/monodoc-1.1.8
        dev-util/pkgconfig
-       app-text/scrollkeeper"
-
-use xine && \
-       G2CONF="${G2CONF} --enable-gstreamer=no" || \
-       G2CONF="${G2CONF} --enable-gstreamer=yes"
-
-
-G2CONF="${G2CONF} $(use_enable aac faad2)"
+       app-text/scrollkeeper
+       gnome-base/gnome-common
+       >=dev-util/intltool-0.29
+       >=dev-util/monodoc-1.1.8"
 
-USE_DESTDIR=1
-DOCS="AUTHORS COPYING ChangeLog INSTALL \
-         MAINTAINERS NEWS README TODO"
+DOCS="AUTHORS COPYING ChangeLog INSTALL MAINTAINERS NEWS README TODO"
 
-AT_M4DIR="${S}/m4"
+# The build is not parallel safe
+MAKEOPTS="${MAKEOPTS} -j1"
 
 pkg_setup() {
        if ! built_with_use sys-apps/dbus mono ; then
@@ -72,22 +60,26 @@ pkg_setup() {
                eerror "dbus, and then emerge muine."
                die "sys-apps/dbus is missing the .NET binding."
        fi
+
+       G2CONF="${G2CONF} $(use_enable aac faad2)"
+
+       if use xine ; then
+               G2CONF="${G2CONF} --enable-xine"
+       else
+               G2CONF="${G2CONF} --enable-gstreamer=0.10"
+       fi
 }
 
 src_unpack() {
        unpack ${A}
        cd ${S}
+
        # Fix the install location of the dbus service file
        sed -i "s:libdir)/dbus-1.0:datadir)/dbus-1:" \
                ${S}/data/Makefile.am || die "sed failed"
 
        intltoolize --force --copy || die "intltoolize failed"
-       eautoreconf
-}
-
-src_compile() {
-       gnome2_src_configure "$@"
-       emake -j1 || die "compile failure"
+       AT_M4DIR="${S}/m4" eautoreconf
 }
 
 src_install() {
@@ -103,4 +95,5 @@ pkg_postinst() {
        einfo "The Gentoo ebuilds will continue to install the plugin, if you don't"
        einfo "want to use the plugin, remove TrayIcon.dll from"
        einfo "/usr/$(get_libdir)/muine/plugins/"
+       einfo
 }