app-admin/sudo: Revbumps to fix error message with USE="-pam"
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 7 Nov 2019 09:52:58 +0000 (10:52 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 7 Nov 2019 09:54:22 +0000 (10:54 +0100)
Reported-by: Saul Peebsen <jaglover@gmail.com>
Tested-by: Saul Peebsen <jaglover@gmail.com>
Closes: https://bugs.gentoo.org/698946
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-admin/sudo/files/sudo-1.8.28-no_pam_error_message_fix.patch [new file with mode: 0644]
app-admin/sudo/sudo-1.8.28_p1-r2.ebuild [moved from app-admin/sudo/sudo-1.8.28_p1-r1.ebuild with 98% similarity]
app-admin/sudo/sudo-1.8.29-r2.ebuild [moved from app-admin/sudo/sudo-1.8.29-r1.ebuild with 98% similarity]

diff --git a/app-admin/sudo/files/sudo-1.8.28-no_pam_error_message_fix.patch b/app-admin/sudo/files/sudo-1.8.28-no_pam_error_message_fix.patch
new file mode 100644 (file)
index 0000000..6931ea2
--- /dev/null
@@ -0,0 +1,46 @@
+
+# HG changeset patch
+# User Todd C. Miller <Todd.Miller@sudo.ws>
+# Date 1573059314 25200
+# Node ID f85ff5ee2caf19cefca67ae49c1d6048d61125cb
+# Parent  5cdcfd9a6c33a157a12f1b1893e397c3198b206b
+Do not warn about a missing /etc/environment file on Linux without PAM.
+Bug #907
+
+diff -r 5cdcfd9a6c33 -r f85ff5ee2caf plugins/sudoers/env.c
+--- a/plugins/sudoers/env.c    Tue Nov 05 15:18:34 2019 -0700
++++ b/plugins/sudoers/env.c    Wed Nov 06 09:55:14 2019 -0700
+@@ -940,7 +940,8 @@
+ #endif /* HAVE_LOGIN_CAP_H */
+ #if defined(_AIX) || (defined(__linux__) && !defined(HAVE_PAM))
+           /* Insert system-wide environment variables. */
+-          read_env_file(_PATH_ENVIRONMENT, true, false);
++          if (!read_env_file(_PATH_ENVIRONMENT, true, false))
++              sudo_warn("%s", _PATH_ENVIRONMENT);
+ #endif
+           for (ep = env.envp; *ep; ep++)
+               env_update_didvar(*ep, &didvar);
+@@ -1218,8 +1219,10 @@
+     efl = calloc(1, sizeof(*efl));
+     if (efl != NULL) {
+       if ((efl->fp = fopen(path, "r")) == NULL) {
+-          free(efl);
+-          efl = NULL;
++          if (errno != ENOENT) {
++              free(efl);
++              efl = NULL;
++          }
+       }
+     }
+     debug_return_ptr(efl);
+@@ -1259,6 +1262,9 @@
+     debug_decl(env_file_next_local, SUDOERS_DEBUG_ENV)
+     *errnum = 0;
++    if (efl->fp == NULL)
++      debug_return_ptr(NULL);
++
+     for (;;) {
+       if (sudo_parseln(&efl->line, &efl->linesize, NULL, efl->fp, PARSELN_CONT_IGN) == -1) {
+           if (!feof(efl->fp))
+
similarity index 98%
rename from app-admin/sudo/sudo-1.8.28_p1-r1.ebuild
rename to app-admin/sudo/sudo-1.8.28_p1-r2.ebuild
index 06397f8cdcbe9762caa0e0cb203520b8e9c2b64e..4c371226f1df22a99c0d8d88bf8233df423c45bf 100644 (file)
@@ -75,6 +75,10 @@ REQUIRED_USE="
 
 MAKEOPTS+=" SAMPLES="
 
+PATCHES=(
+       "${FILESDIR}/${PN}-1.8.28-no_pam_error_message_fix.patch" #698946
+)
+
 src_prepare() {
        default
        elibtoolize
similarity index 98%
rename from app-admin/sudo/sudo-1.8.29-r1.ebuild
rename to app-admin/sudo/sudo-1.8.29-r2.ebuild
index 4aba6ef09a1a8cd895657eb320804a04c98df717..3f019d90fd06766cecaa595af5883a2db5de54af 100644 (file)
@@ -75,6 +75,10 @@ REQUIRED_USE="
 
 MAKEOPTS+=" SAMPLES="
 
+PATCHES=(
+       "${FILESDIR}/${PN}-1.8.28-no_pam_error_message_fix.patch" #698946
+)
+
 src_prepare() {
        default
        elibtoolize