Improvements suggested by Sideris Michael <msid@daemons.gr> on bug #157434. Pruned...
authorJoshua Nichols <nichoj@gentoo.org>
Mon, 11 Dec 2006 02:13:44 +0000 (02:13 +0000)
committerJoshua Nichols <nichoj@gentoo.org>
Mon, 11 Dec 2006 02:13:44 +0000 (02:13 +0000)
Package-Manager: portage-2.1.2_rc2-r5

xfce-extra/xfmedia/ChangeLog
xfce-extra/xfmedia/files/digest-xfmedia-0.9.2-r1 [new file with mode: 0644]
xfce-extra/xfmedia/xfmedia-0.9.2-r1.ebuild [new file with mode: 0644]

index 3fc84b0c6d4d52ae3141ff43a3010ab39766af48..dc5c9f3c15720b27870319b34e1aac7ec6392275 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for xfce-extra/xfmedia
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfmedia/ChangeLog,v 1.13 2006/12/07 05:25:50 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfmedia/ChangeLog,v 1.14 2006/12/11 02:13:44 nichoj Exp $
+
+*xfmedia-0.9.2-r1 (11 Dec 2006)
+
+  11 Dec 2006; Joshua Nichols <nichoj@gentoo.org> -xfmedia-0.9.1-r1.ebuild,
+  -xfmedia-0.9.1-r2.ebuild, -xfmedia-0.9.2.ebuild, +xfmedia-0.9.2-r1.ebuild:
+  Improvements suggested by Sideris Michael <msid@daemons.gr> on bug #157434.
+  Pruned old revisions.
 
 *xfmedia-0.9.2 (07 Dec 2006)
 
diff --git a/xfce-extra/xfmedia/files/digest-xfmedia-0.9.2-r1 b/xfce-extra/xfmedia/files/digest-xfmedia-0.9.2-r1
new file mode 100644 (file)
index 0000000..b580fba
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6eb8bd1f67201f829e0f45e733c02bd5 xfmedia-0.9.2.tar.bz2 893228
+RMD160 e1d16fe50609475f916594f2b6a885cfed6251e0 xfmedia-0.9.2.tar.bz2 893228
+SHA256 451b67541527cde7f96693fa1ef7776eb03ac40edcef3023bfb2c1ebcf3e7e0c xfmedia-0.9.2.tar.bz2 893228
diff --git a/xfce-extra/xfmedia/xfmedia-0.9.2-r1.ebuild b/xfce-extra/xfmedia/xfmedia-0.9.2-r1.ebuild
new file mode 100644 (file)
index 0000000..bb0bea5
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfmedia/xfmedia-0.9.2-r1.ebuild,v 1.1 2006/12/11 02:13:44 nichoj Exp $
+
+inherit xfce44
+
+DESCRIPTION="Xfce4 media player"
+HOMEPAGE="http://spuriousinterrupt.org/projects/xfmedia"
+SRC_URI="http://spuriousinterrupt.org/projects/${PN}/files/${P}.tar.bz2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="dbus debug startup-notification"
+
+DEPEND=">=dev-util/intltool-0.31
+       x11-libs/libX11
+       x11-libs/libSM
+       >=dev-libs/glib-2.6.0
+       >=x11-libs/gtk+-2.6.0
+       >=xfce-base/libxfce4util-4.2.0
+       >=xfce-base/libxfcegui4-4.2.0
+       >=media-libs/xine-lib-1.0.0
+       >=xfce-extra/exo-0.2
+       startup-notification? ( >=x11-libs/startup-notification-0.5 )
+       dbus? || (
+                       >=dev-libs/dbus-glib-0.71
+                       ( <sys-apps/dbus-0.90
+                       >=sys-apps/dbus-0.34 )
+       )
+       media-libs/taglib"
+RDEPEND="${DEPEND}"
+
+XFCE_CONFIG="$(use_enable debug) \
+       $(use_enable startup-notification) \
+       $(use_enable dbus)"