media-libs/libopenshot-audio: bump version to 0.1.9_pre20190502
authorStefan Strogin <steils@gentoo.org>
Wed, 12 Jun 2019 15:16:13 +0000 (18:16 +0300)
committerStefan Strogin <steils@gentoo.org>
Thu, 13 Jun 2019 15:30:44 +0000 (18:30 +0300)
Closes: https://bugs.gentoo.org/685136
Closes: https://bugs.gentoo.org/685202
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Stefan Strogin <steils@gentoo.org>
media-libs/libopenshot-audio/Manifest
media-libs/libopenshot-audio/libopenshot-audio-0.1.9_pre20190502.ebuild [new file with mode: 0644]

index ffb31e8795984aa0bdfd2975589089de57f839ec..e57ee1fb56fc59351b047c2c4ca23dcd74380606 100644 (file)
@@ -1 +1,2 @@
 DIST libopenshot-audio-0.1.4.tar.gz 2959997 BLAKE2B 0736d9f4877f46ac90fd236cbdcfce8c1f66f5ac5d5e9762672a4eaeb668eb61a5f1e45996f0feea604d2c30891198fa58fc89f360815336ea18311d019fed2c SHA512 5605164a8c66c33ac893cc2b42cdacffff03eb156a61740c1b2c00dd7e7602a802fa1dc3795c620810e3ee29a290aa6bae8b62bc17eab3f4dd2d8052e0481824
+DIST libopenshot-audio-0.1.9_pre20190502.tar.gz 1696201 BLAKE2B 6bc0be3f8374f734cb6b7271c09dad8f7da794acb87236441f41999fab9baa3fee69d6a820db51a4c116b3a5113bb8f72da396babd13511d013b8ffafc2c1bf7 SHA512 73ba3e2054de1b74e6ae7c874a61388220efe12b640f741d5e18d9b242d427fd0fc82b03527af7de64ecd6dbe0a450b884c8557bb5a51493be21838e1f4dfd1a
diff --git a/media-libs/libopenshot-audio/libopenshot-audio-0.1.9_pre20190502.ebuild b/media-libs/libopenshot-audio/libopenshot-audio-0.1.9_pre20190502.ebuild
new file mode 100644 (file)
index 0000000..c04e18d
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+COMMIT="77edb1f14dde35e1facecc309dbc4fb7f07d7014"
+
+DESCRIPTION="Library for audio editing and playback used by OpenShot"
+HOMEPAGE="https://www.openshot.org/"
+SRC_URI="https://github.com/OpenShot/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       media-libs/alsa-lib
+       media-libs/freetype
+       x11-libs/libX11
+       x11-libs/libXcursor
+       x11-libs/libXext
+       x11-libs/libXinerama
+       x11-libs/libXrandr
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"