games-action/violetland: Version bump to 0.5, EAPI 7
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 10 Nov 2019 12:21:05 +0000 (12:21 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 10 Nov 2019 12:23:48 +0000 (12:23 +0000)
Package-Manager: Portage-2.3.79, Repoman-2.3.17
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-action/violetland/Manifest
games-action/violetland/metadata.xml
games-action/violetland/violetland-0.5.ebuild [new file with mode: 0644]

index d496ae503d518d8314307f6e5c745cfe29556f86..36b692b15f7ee273f64efad9b9f2ebb9b334cc10 100644 (file)
@@ -1 +1,2 @@
 DIST violetland-0.4.3.tar.gz 9257919 BLAKE2B 255c9c13a49db576a37dbd4aa863306f0778f9528173426b26934a674dd0145574ff96242577feff8a4566571eebd97d0cb7a1d8a9718ac84fcd6c4492230fd5 SHA512 678e1aea42c9358794c6b8b83bdd113baf26e16db4cb815c756cb6c1d268b8210d18a47d1a98a019556633b4db62cd8cf7fc6a1e1ec3b7e3647a9d8353020fae
+DIST violetland-0.5-source-with-dependencies.tar.gz 11495885 BLAKE2B 33c3e8a8955ddc416c66c761681dce337ecccdb52ae7be3777124f4854c325436296ea5614100527a3e5be6c4d3a3cf2dffb2336037d5e904b50e2ae843d0fc4 SHA512 9b00fa600332c956c49bc5906f373c0dfff08a13320617014942ac4dbc199de8f84bef87ed218b38812ae3c53622e9148aa4463c4ea219056360bff1c73b7f88
index 21c980e6339f4e933b34b93bf5b1fa99a6deacb4..243f8b1823534d5a0a16c64221b53bf3c6d6d4e0 100644 (file)
@@ -6,6 +6,6 @@
                <name>Gentoo Games Project</name>
        </maintainer>
        <upstream>
-               <remote-id type="github">violetland</remote-id>
+               <remote-id type="github">ooxi/violetland</remote-id>
        </upstream>
 </pkgmetadata>
diff --git a/games-action/violetland/violetland-0.5.ebuild b/games-action/violetland/violetland-0.5.ebuild
new file mode 100644 (file)
index 0000000..7078f00
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop xdg-utils
+
+DESCRIPTION="Help a girl named Violet in the struggle with hordes of monsters"
+HOMEPAGE="https://violetland.github.io/"
+SRC_URI="https://github.com/ooxi/${PN}/releases/download/${PV}/${P}-source-with-dependencies.tar.gz"
+
+LICENSE="GPL-3 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-libs/boost:=[threads(+)]
+       media-libs/libsdl[sound,video]
+       media-libs/sdl-image[png]
+       media-libs/sdl-mixer[vorbis]
+       media-libs/sdl-ttf
+       virtual/opengl
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+       sys-devel/gettext
+"
+
+src_prepare() {
+       cmake-utils_src_prepare
+
+       # Bizarrely fcitx is only bundled for a CMake module to find libintl
+       # but let's make sure the rest remains unused.
+       rm -r lib/fcitx/src || die
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DDATA_INSTALL_DIR="${EPREFIX}/usr/share/${PN}"
+               -DLOCALE_INSTALL_DIR=share/locale
+       )
+
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       dodoc CHANGELOG.md CONTRIBUTORS.md
+
+       # Remove duplicate READMEs.
+       rm -r "${ED}"/usr/share/${PN}/README* || die
+
+       newicon -s 64 icon-light.png ${PN}.png
+       make_desktop_entry ${PN} VioletLand
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }