dev-ros/hector_imu_tools: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 28 Sep 2015 12:52:29 +0000 (14:52 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 28 Sep 2015 12:52:29 +0000 (14:52 +0200)
Package-Manager: portage-2.2.22

dev-ros/hector_imu_tools/Manifest [new file with mode: 0644]
dev-ros/hector_imu_tools/hector_imu_tools-0.3.3.ebuild [new file with mode: 0644]
dev-ros/hector_imu_tools/hector_imu_tools-9999.ebuild [new file with mode: 0644]
dev-ros/hector_imu_tools/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/hector_imu_tools/Manifest b/dev-ros/hector_imu_tools/Manifest
new file mode 100644 (file)
index 0000000..8dc36f5
--- /dev/null
@@ -0,0 +1 @@
+DIST hector_slam-0.3.3.tar.gz 64368 SHA256 e3da461e7e4020218ae3d26f2eb6e135d1ac486bb0dab52f60e9d2349c637e5c SHA512 755a639b865d897281f01e28ca8dcdf943d953422f38ba73ed7e982c22c178cb5becbb9d2962420136cad0927f5c412ce896fc9b1995b58d7163fb35a82c62c0 WHIRLPOOL 4813768350cb232d4171a2f1335472e07ddb526b8846f56f3820a2dd4c51673d3c26866554e1a5b3e097530265efd104bd2a5eeda7c25639af991b4696971d4d
diff --git a/dev-ros/hector_imu_tools/hector_imu_tools-0.3.3.ebuild b/dev-ros/hector_imu_tools/hector_imu_tools-0.3.3.ebuild
new file mode 100644 (file)
index 0000000..88c0c7b
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for processing IMU messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/roscpp
+       dev-ros/tf
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_imu_tools/hector_imu_tools-9999.ebuild b/dev-ros/hector_imu_tools/hector_imu_tools-9999.ebuild
new file mode 100644 (file)
index 0000000..88c0c7b
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for processing IMU messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/roscpp
+       dev-ros/tf
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_imu_tools/metadata.xml b/dev-ros/hector_imu_tools/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>