dev-python/zc-lockfile: Version bump to 2.0
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 21 Nov 2019 22:16:20 +0000 (14:16 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 21 Nov 2019 23:55:12 +0000 (15:55 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/zc-lockfile/Manifest
dev-python/zc-lockfile/zc-lockfile-2.0.ebuild [new file with mode: 0644]

index cc657aa92f0cc054f6c5da8b59f8bc6ee7daa2ed..9cc5fa579c3a65e517b91e4dce7172a6074ad8f0 100644 (file)
@@ -1 +1,2 @@
 DIST zc.lockfile-1.4.tar.gz 11075 BLAKE2B 4fcc18b4d337c1b102916588aef7271fe189f30e442b5d2180b5a20d804f84649d4bf9dc6f601e6b7ee38c4a436c3848b83cbcb1a19974acdf072347b6822b83 SHA512 f145c34088770b50002d1caa88876f9fb11f3b9810fe68b8e1a38d27084d27ce058883228469abb05811f3f11a7b94acdaad8392eb1b6c34c98ddc885cdf77be
+DIST zc.lockfile-2.0.tar.gz 11923 BLAKE2B 7609f64eef4521f0aa95dc899b253570a317bd997cced00665a2dbe22cf7f834ce75daaf4fdf79520157dee31742758aad1844d49c5eccb780e7d5fd2e8e5ac5 SHA512 2586bafacb12540383695a24cb01fd284e61bfa3fcb16431ed0e91278e547c68983363fb69c1ffbd54f7c22db43300ba018ccd2fb3e21666c98860415b7a3c3b
diff --git a/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild b/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild
new file mode 100644 (file)
index 0000000..66a9711
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Basic inter-process locks"
+HOMEPAGE="https://pypi.org/project/zc.lockfile/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( CHANGES.rst README.rst )
+
+distutils_enable_tests nose
+
+# Prevent incorrect installation of data file
+python_prepare_all() {
+       sed -e '/^    include_package_data/d' -i setup.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_install() {
+       distutils-r1_python_install
+
+       python_moduleinto zc
+       python_domodule src/zc/__init__.py
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       find "${D}" -name '*.pth' -delete || die
+}