dev-python/sphinxcontrib-newsfeed: add version 0.1.4
authorAlex Brandt <alunduil@gentoo.org>
Sun, 9 Aug 2015 17:29:02 +0000 (12:29 -0500)
committerAlex Brandt <alunduil@gentoo.org>
Sun, 9 Aug 2015 17:30:19 +0000 (12:30 -0500)
Package-Manager: portage-2.2.20

dev-python/sphinxcontrib-newsfeed/Manifest [new file with mode: 0644]
dev-python/sphinxcontrib-newsfeed/metadata.xml [new file with mode: 0644]
dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinxcontrib-newsfeed/Manifest b/dev-python/sphinxcontrib-newsfeed/Manifest
new file mode 100644 (file)
index 0000000..1f6429b
--- /dev/null
@@ -0,0 +1 @@
+DIST sphinxcontrib-newsfeed-0.1.4.tar.gz 10862 SHA256 f78c865b1a32d249644a9c46f395b547df0dc21ed69b70898d64235b4755efb4 SHA512 96d9d0c15fca8b62f945bafc8f0eafa62df9c471f7510e2f153e47b66534e5f3041e5c01df772e6c35a9f09baa70064642f7f0fa43ccfd33dd64c2604494f2fc WHIRLPOOL f14e5c8e9a5b6c35ae1311ed2efa9c8e71223c1d35bbe09dc1f097d07547748b8f73aa7170e1b422681cac44d40524ea5e017bc2b730f7581f1d91c9b057adc0
diff --git a/dev-python/sphinxcontrib-newsfeed/metadata.xml b/dev-python/sphinxcontrib-newsfeed/metadata.xml
new file mode 100644 (file)
index 0000000..02be8c5
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>alunduil@gentoo.org</email>
+               <name>Alex Brandt</name>
+       </maintainer>
+       <longdescription lang="en">
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
new file mode 100644 (file)
index 0000000..5e23f6a
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="News Feed extension for Sphinx"
+HOMEPAGE="http://bitbucket.org/prometheus/sphinxcontrib-newsfeed"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_install_all() {
+       use examples && local EXAMPLES=( demo/. )
+
+       distutils-r1_python_install_all
+}