dev-ada/aws: simplify using ada eclass
authorTupone Alfredo <tupone@gentoo.org>
Tue, 17 Sep 2019 06:53:13 +0000 (08:53 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Tue, 17 Sep 2019 06:53:13 +0000 (08:53 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-ada/aws/aws-2018-r2.ebuild [new file with mode: 0644]
dev-ada/aws/aws-2019-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ada/aws/aws-2018-r2.ebuild b/dev-ada/aws/aws-2018-r2.ebuild
new file mode 100644 (file)
index 0000000..f8ec2e2
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ADA_COMPAT=( gnat_201{6,7,8,9} )
+inherit ada multiprocessing
+
+MY_P=${PN}-gpl-${PV}-src
+
+DESCRIPTION="A complete Web development framework"
+HOMEPAGE="http://libre.adacore.com/tools/aws/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5b0819e0c7a447df26c27abd
+       -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-ada/xmlada[${ADA_USEDEP},shared,static-libs]"
+DEPEND="${RDEPEND}
+       dev-ada/asis[${ADA_USEDEP}]
+       dev-ada/gprbuild[${ADA_USEDEP}]"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2016-gentoo.patch
+       "${FILESDIR}"/${PN}-2018-gentoo.patch
+)
+
+src_configure() {
+       emake -j1 setup prefix=/usr ENABLE_SHARED=true \
+               GPRBUILD="/usr/bin/gprbuild -v"
+}
+
+src_compile() {
+       emake \
+               PROCESSORS=$(makeopts_jobs) \
+               GPRBUILD="/usr/bin/gprbuild -v"
+}
diff --git a/dev-ada/aws/aws-2019-r1.ebuild b/dev-ada/aws/aws-2019-r1.ebuild
new file mode 100644 (file)
index 0000000..c45e75c
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ADA_COMPAT=( gnat_2019 )
+inherit ada multiprocessing
+
+MY_P=${P}-20190512-18AB9-src
+
+DESCRIPTION="A complete Web development framework"
+HOMEPAGE="http://libre.adacore.com/tools/aws/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5cdf85a031e87aa2cdf16b19
+       -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-ada/xmlada[${ADA_USEDEP},shared,static-libs]"
+DEPEND="${RDEPEND}
+       dev-ada/asis[${ADA_USEDEP}]
+       dev-ada/gprbuild[${ADA_USEDEP}]"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2016-gentoo.patch
+)
+
+src_configure() {
+       emake -j1 setup prefix=/usr ENABLE_SHARED=true \
+               GPRBUILD="/usr/bin/gprbuild -v"
+}
+
+src_compile() {
+       emake \
+               PROCESSORS=$(makeopts_jobs) \
+               GPRBUILD="/usr/bin/gprbuild -v"
+}