media-video/dvdrip: Remove media-video/libav
authorDavid Seifert <soap@gentoo.org>
Sun, 26 Apr 2020 12:25:42 +0000 (14:25 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 26 Apr 2020 12:25:42 +0000 (14:25 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: David Seifert <soap@gentoo.org>
media-video/dvdrip/dvdrip-0.98.11-r4.ebuild
media-video/dvdrip/files/dvdrip-0.98.11-libav.patch [deleted file]

index e6bca9fb326a972bcf4378c73469cc900bae8c69..e26b6462724ba65de329a9a1d81694cfb8a37e82 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -10,7 +10,7 @@ SRC_URI="https://www.exit1.org/dvdrip/dist/${P}.tar.gz"
 
 SLOT="0"
 KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="ffmpeg fping libav mplayer ogg subtitles vcd vorbis xine xvid"
+IUSE="ffmpeg fping mplayer ogg subtitles vcd vorbis xine xvid"
 
 DEPEND=">=dev-perl/Event-ExecFlow-0.64
        >=dev-perl/Event-RPC-0.89
@@ -24,10 +24,7 @@ DEPEND=">=dev-perl/Event-ExecFlow-0.64
 RDEPEND="${DEPEND}
        x11-libs/gdk-pixbuf:2[jpeg]
        x11-libs/gtk+:2
-       ffmpeg? (
-               libav? ( media-video/libav )
-               !libav? ( media-video/ffmpeg:0 )
-       )
+       ffmpeg? ( media-video/ffmpeg:0 )
        fping? ( >=net-analyzer/fping-2.2 )
        mplayer? ( media-video/mplayer )
        ogg? ( media-sound/ogmtools )
@@ -54,9 +51,6 @@ src_prepare() {
        epatch "${FILESDIR}"/${P}-fix_parallel_make.patch
        # Fix default device for >=udev-180 wrt #224559
        sed -i -e 's:/dev/dvd:/dev/cdrom:' lib/Video/DVDRip/Config.pm || die
-
-       # Ubuntu patch for supporting libav
-       use libav && epatch "${FILESDIR}"/${P}-libav.patch
 }
 
 src_install() {
diff --git a/media-video/dvdrip/files/dvdrip-0.98.11-libav.patch b/media-video/dvdrip/files/dvdrip-0.98.11-libav.patch
deleted file mode 100644 (file)
index a9d60e2..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-Description: Port from ffmpeg to avconv.
-Author: Dmitrijs Ledkovs <xnox@ubuntu.com>
-
---- dvdrip-0.98.11.orig/lib/Video/DVDRip/Depend.pm
-+++ dvdrip-0.98.11/lib/Video/DVDRip/Depend.pm
-@@ -114,10 +114,10 @@ my %TOOLS = (
-     },
-     ffmpeg => {
-         order       => ++$ORDER,
--        command     => "ffmpeg",
-+        command     => "avconv",
-         comment     => __ "FFmpeg video converter command line program",
-         optional    => 1,
--        version_cmd => "ffmpeg -version",
-+        version_cmd => "avconv -version",
-         get_version => sub {
-             my ($cmd) = @_;
-             qx[$cmd 2>&1] =~ /version ([^\s]+)/i;
---- dvdrip-0.98.11.orig/lib/Video/DVDRip/Title.pm
-+++ dvdrip-0.98.11/lib/Video/DVDRip/Title.pm
-@@ -3184,7 +3184,7 @@ sub get_take_snapshot_command {
-         . "tcdemux -s 0x80 -x mpeg2 -S $grab_options->{S} "
-         . "-M 0 -d 0 -P /dev/null | "
-         . "tcextract -t vob -a 0 -x mpeg2 -d 0 | "
--        . "ffmpeg -r $frame_rate -i - -an -r 1 -ss '$start' -vframes 1 snapshot%03d.png ";
-+        . "avconv -r $frame_rate -i - -an -r 1 -ss '$start' -vframes 1 snapshot%03d.png ";
-     $command .= " && "
-         . "execflow convert"