dev-python/regex: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 09:20:17 +0000 (10:20 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 13:38:53 +0000 (14:38 +0100)
dev-python/regex/Manifest
dev-python/regex/regex-2016.01.10.ebuild [deleted file]

index 1a5af93eaae7a20d628c821007f3ab64ce506131..0aa6eae27c31a3d949ae4d50bf8a14118e01de5b 100644 (file)
@@ -1,2 +1 @@
-DIST regex-2016.01.10.tar.gz 574017 BLAKE2B a9411450fe2864c8b088aa97b8591df64b5149c54984c8c014f498a209dcf665e65df29088495fdca2b3dc7aad72bf3064611b6a061d6bd89ddc1624679c5a13 SHA512 4f4700ca746763f857449003d32d56b5aa8069e3b71b160e719633b0cf00f80efc0766d8e1e193977278f91bd3e73c87aab31bee23aec77557ac9b3652ff6a2f
 DIST regex-2017.04.05.tar.gz 601638 BLAKE2B a7c094887b602f24e68c51c92098604c462d506b13f064beaebdec081fd28d39dac9934fface0de0444dc6145af5f4c0e8ab2cd3b65ecfc2c1ca522682b3bf95 SHA512 4c3e440e11f57e2323892e10fbed7f2c89b35771fdc970164ba69bb154dde535f6edb51a0997c924eb776c61e5efd1d04001abd343110518a89b5b7bf148ae49
diff --git a/dev-python/regex/regex-2016.01.10.ebuild b/dev-python/regex/regex-2016.01.10.ebuild
deleted file mode 100644 (file)
index e682641..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Alternative regular expression module to replace re"
-HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="doc"
-
-DOCS=( README docs/UnicodeProperties.txt )
-
-python_compile() {
-       if ! python_is_python3; then
-               local CFLAGS=${CFLAGS}
-               append-cflags -fno-strict-aliasing
-       fi
-       distutils-r1_python_compile
-}
-
-python_test() {
-       local msg="tests failed under ${EPYTHON}"
-       # https://bitbucket.org/mrabarnett/mrab-regex/issue/145/1-fail-in-testsuite-under-pypy
-       einfo "There is one trivial fail of test test_empty_array under pypy"
-
-       if python_is_python3; then
-               "${PYTHON}" Python3/test_regex.py || die $msg
-       else
-               "${PYTHON}" Python2/test_regex.py || die $msg
-       fi
-}
-
-python_install_all() {
-       local DOCS="${DOCS} docs/UnicodeProperties.txt"
-       use doc && local HTML_DOCS=( docs/Features.html )
-
-       distutils-r1_python_install_all
-}